TOW Stage 3 - event not recorded

My ride in Tour of Watopia (Stage 3) @11:00 BST today (11/04/2021) was not uploaded to my account on Zwift. After 20 minutes all my riding companions (800+ of them) disappeared. I had to complete the remaining 50 minutes on my own. I notice from ZwiftPower results for the event that only 350+ riders were recorded as completing the event, so I was not the only one experiencing this problem. I have a WIFI booster in my garage where I have my turbo set up, and have a good strong WIFI signal, therefore I do not regard the problem being at my end. By downloading the FIT file I have been able to upload the (complete) ride to STRAVA - but my record of competing in this event, and the stats, are not in my ZWIFT profile.

Ahh… this is one of those cases where it’s on Strava and it still doesn’t exist! LOL. Quite frankly, given that the “B” route can be traversed in about half an hour, you’re probably better off just re-riding the route than wasting further time seeking support from Zwift or this forum. You’ll still get the “tick” mark for stage completion, and you’ll know in your own heart that you’ve done the deed twice. Luck!

1 Like

You had a network drop at some point. I’d suggest you look into addressing the cause otherwise this is likely to repeat itself (whether its an event or just a ride).

Rebooting your internet modem is a good place to start followed by checking your wifi channels for contention (if your Zwift device uses wifi). You can also throw your log file onto and see if that highlights anything (consistent problem or one-off), and even have a read of it to see if anything stands out as obviously not good.

If you need advice on any of this type of stuff, just post here - plenty of people here will happily help out.

1 Like

Hi I’ve just done stage 4 - road to ruins C - and I didn’t get my tick - how can I have this corrected?? Thx!

Yes the same for me in TOW4 this morning. How is it possible to fix this bullshit. because my bike got connected 20" late, TOW4 isn’t validated whereas I completed more than distance

Same here for me this morning - TOW Stage 4, A group, 10am. Doesn’t register as completed. This happens way too often and it’s not my network dropping out, equipment failure of any kind. I have wired gigabit Ethernet (Fios Fiber) direct to my macbookPro which only runs Zwift. There was a problem at the beginning of the ride where the leaderboard and ranking didn’t display properly and many people commented about it. At the end of the day I burned over 1k calories and all good but it drives me crazy when things don’t work reliably, and this definitely is a crapshoot.