Terminal opens up on Mac

This topic has been discussed before but that was some four years ago. Plus I have a slightly different problem besides the headline.
When I click Zwift from my dock, a terminal opens up and lots of text scroll down extremely rapidly and finally I am asked to key in my password. It works fine after that.
If I open Zwift from my applications folder it automatically logs me on (I guess I had set it up that way) but then I find Zwift cannot recognise my trainer.
The terminal opening up per se is not an annoying problem for me. But why can’t Zwift see my trainer when I try to log in from the applications folder. They cannot be two different softwares. Or are they?
Should I uninstall it all and reinstall?

To keep it simple, I would:

  1. Delete the Zwift launcher from the Dock.
  2. Go to Applications and delete the Zwift app itself.
  3. Go to your Documents folder. You should find a Zwift folder. Instead of deleting it, how about you rename it to something like “Old_Zwift” for now. You might want something in it later.
  4. Empty your trash.
  5. Reinstall Zwift.
1 Like

Thanks a lot Lin-Alan for your response. I did find the Zwift folder in my documents and have already renamed it. Actually every time after my ride I import the data into my Garmin Connect, so the data is there in any case.
Regarding your suggestion, if I am not mistaken, between 4 and 5 there should be another step - switch off and switch on the machine. Last time I reloaded Zwift I forgot to do this :slight_smile: and nothing much changed. I will try it again now.
But before that, being a little techno-phobic I want to download Zwift in my daughter’s laptop and see that it connects from there :slight_smile:
It is very disconcerting to find that Zwift cannot recognise my trainer and I am going on a very difficult climb for which I am training right now. So don’t really want to disturb something that’s somewhat working for me. Also, being in India net connection speed is just not dependable.

The problem stands solved Lin-Alan. Thanks. I did what you said but also downloaded Zwift in my daughter’s machine as a back up. Now it works straight from both the computers without a hitch or terminal.