Tacx Vortex & Garmin heart rate strap = no resistance control


(Bodo Riepl) #1

Vortex Firmware 3.1.14

Suunto Ant+ Ministick

 

if i connect my garmin heart rate strap my vortex get any resistance changes. If i disconnect the strap everything ist OK?

Does somebody have an idea?


(Bodo Riepl) #2

of course Vortex Firmware is 3.1.13 :wink:


(Johan Lindh SZR) #3

Have the same problem. But i have a andriod phone and Tacx utility (latest version) tells me I have the latest version, 3.1.9… 


(Marcin Przybylski) #4

Somebody already said about this problem. The thing is that you mus disconnect your bluetooth tranmission with the phone. Had the same issue. There is a problem with bluetooth and ant+ at the same time. So I suppose the best option is to have the ant+ heart rate transmitter and not using bluetooth. 

 


(Johan Lindh SZR) #5

Yes I know. The trainer isn’t connected to the phone with Bluetooth when I’m on zwift . Even tried with the phone turned off. The problem is i can’t upgrade to 3.1.13 since I have and android and tacx haven’t realised new upgrades to tacx utility for android but they have for ios. At least I think it’s an upgrade problem 


(Johan Lindh SZR) #6

Oh, hearthrate monitor and resistance on trainer worked fine before latest upgrade of zwift


(Bodo Riepl) #7

have connected my vortex and my strap via ANT+, no BT at all!


(Johan Lindh SZR) #8

Same


(Bodo Riepl) #9

found a workaround today, maybe there will be an  easier way to fix. Have tested thos one time, hope this will work in future again - and think btw this procedure have to be done everytime you like to ride :frowning:

  • start Zwift

  • disconnect/unpair the Vortex in Zwift (i also unoair the cadence sensor)

  • unplug the Vortex from power

  • plug in the power cable of the Vortex again

  • search the Vortex in Zwift an pair again / cadence ist selected automatically

  • search the heart rate strp

 

and voila: all ist working

 

Crazy but true - also crazy we have to this again and agein whnen start a ride :frowning:


(Greg Hodgins) #10

Same problem here. Garmin ANT stick and Vortex TDF with latest firmware. It worked once so I know it is functional. Thanks for the ideas - both making sure a spare iPhone I have sitting by for the update (I use Android and was lucky to have a kid with an old iPhone so I could do the required upgrade) and checking calibration is disconnected, and the sequence of startup. I was playing with the same. I was also wondering whether cadence should come from trainer or Powertap as I also have power.

Everything is made more complicated and frustrating by having to exit Zwift and key in username every time. A couple lines of code to remember last username.

Thanks again.


(Adam Hoare RGD) #11

I have had the same problem, I’m running tracx I-vortex trainer with tracx ant stick on my laptop, it was working fine until some time last week and now I have no resistance. I have tried un-installing and re-installing zwift, un-pairing all devices and re-add them, moving my ant stick around to see is this works but sadly everything I have tried hasn’t worked???

 

Regards

 

Adam