Tacx plagued by Bluetooth dropouts

I’ve been happily Zwift since October last year. I don’t think I’ve seen a single drop out until this week. On Monday I had to abandon my workout because the connection to my KICR Core kept dropping out. Rode again last night and had one drop out early on that meant I dropped from the group and was too far behind to catch up and a 2nd drop out late in the workout.

I’m struggling to understand what’s changed. I ride with Bluetooth headphones which have been absolutely fine to date. I turned them off after my first drop out last night to see if that was the problem, but it still happened later in the ride. My wife uses a treadmill in the same room with a Bluetooth HR monitor, but this has worked fine for months without a single issue.

Is there anyway I can identify what is causing the Bluetooth interference? I spent most of my time in Zwift in group rides or races. When a single drop out causes you to drop out of the group and makes the entire session pointless, I can’t see myself continuing with zwift if I can’t get this issue resolved. Which would be a massive shame because I’ve been loving it way more than I thought I would!

Did you try to put your log file in Zwiftalizer.com? That may help you find the issue.

I had the same on Monday night. Been using fine for the last year and dropped three times until I gave up. Seems to be working fine again now though.

I use the companion app on an iPhone to link through a computer.

For me it dropped out each time I tried to up the work out intensity in ERG mode.

2 Likes

This is a great tool! Thx for the link

Have you changed your wifi setup, bought a new microwave oven or other electrical device. A simple change of wifi channel can sometimes help.

I’m having the same issue, only with my ATV 4K. Been working fine for a month (since I got it). Then one day I had a few drops, and now it won’t even connect. I always get “No Signal” on my Kickr connection. To my knowledge, that means the ATV sees the trainer but can’t pair with it. I’ve done factory resets, turned off as many bluetooth devices as possible, to no avail. I may return the 4K to the Apple Store and see what they can diagnose, because my iPhone and older ATV don’t have this problem.

Same here. When Zwift is on my Bose QuiteControl stop producing any sound. It is clearly impact of Zwift.

Same here. Have lost Bluetooth a couple of times. Go to reconnect, it says no signal then it does pair. Go back into the ride and the power meter is blank once again! Extremely annoying as it was working fine for 95%of the time.

1 Like

Nathan. What fixed the issue for you? I’m having exactly the same issue with multiple Bluetooth drop outs mid-ride which is making racing impossible. My connections are stable with other apps (e.g tacx) but zwift is virtually unusable. Cheers. Mark

Honestly, I’m not sure. I did use http://zwiftalizer.com/ and that provided some recommendations which seemed to help but not eliminate the issue. I also set the house wifi to be on a specific channel away from ANT+ range which may have helped. There are some good tips in this zwiftinsider post https://zwiftinsider.com/how-to-fix-ant-dropouts-in-zwift/

Thanks for the link Nathan. I’ll take a look. Zwiftalizer showed multiple ant+ dropouts but I was connected purely on Bluetooth, so that’s something I’ll look at. I have to admit it is pretty galling that nothing else I connect via Bluetooth ever drops out, just Zwift.

1 Like

Hi Nathan.

I’ve just found a post on the zwift forum from Dazzler about tacx flow smart trainers overheating during workouts with low cadence and watts over 250. Sharing in case useful:

Does this sound familiar? Hi. I’m sharing this because it’s taking me months to look in the right place for the problem, and someone may find it helpful.

For quite a while now, I’ve been experiencing bluetooth/power/resistance dropouts mid races/workouts. It normally happens when climbing or in longer races mostly. Lots of other people seem to be posting the same issue, and the discussion has centred on ANT/Bluetooth overload/proximity etc. I’ve tried all of the potential fixes over the past 18 months, but still get intermittent issues. It can go numerous times in one session and I have to wait, re-pair and hope it doesn’t happen again… before having to ditch the session in frustration. Sound familiar?

This week, halfway up Alpe Du Zwift, it happened BUT after re-pairing several times, and spitting a few swear words, a thought occurred - could the turbo unit itself be overheating? (I know I was.) I trained a fan on it - and didn’t get the problem again. All this time thinking it was a more technical issue. Here’s a forum on Garmin (only just found) that speaks of the same issues… :+1:

https://forums.garmin.com/sports-fitness/indoor-training/f/tacx-flow/219757/flow-smart-overheating-at-low-rpm-and-high-power

I have been having the same issue, this is what I have found.
My laptop is how I connect to the device via bluetooth, it would connect and and then as I start to ride drop out, very frustrating.
What was the cause?, My laptop was connected to my router via wifi 2.4G and with the bluetooth device also using 2.4G it creates an issue.
My router also has 5G, so a simple change to wifi 5G and no further issues :slight_smile: