Tacx Neo - Choice of disabling road patterns

While I like this feature there are times where I’d rather have a workout without the road pattern vibration. Would be great to have a menu item allowing you to switch it on and off.

Hi Andreas,

Actually, it’s in the Settings Menu in-game :slight_smile: Also, it is automatically disabled for workouts.

Hi Eric

That’s weird, I could have sworn that it wasn’t there when I checked yesterday.

Anyway, thanks for the quick answer and for having this option!


i do not see any road patterns when i start up with my taxc neo. 

how can i activate them?

i have the latest firmware on neo.

Strange. I have a Tacx Neo as well, and don’t see any such option. Maybe because it’s not currently paired. I bet this is the problem. Will see next time.



It was a few months ago, but I believe the solution was to re-launch Zwift with the Tacx Neo powered up. The new option appeared once the Neo was connected, setup, taken on a test ride and restarted. I believe that after restarting, the new option appeared, and you could enable/disable. With the settings now saved, it automatically launches with the saved configurations.

Zwift can you clarify “automatically disabled”? Do you mean it automatically toggles to off, but can be overridden in the settings during a workout to be ON? Or does this mean regardless of if the setting is on or off, it’s disabled during a workout?

I turned it ON during a workout but didn’t feel the road effects. Unfortunately this is my 2nd Tacx Neo in a month, so I’m hoping this isn’t an issue with my device specifically.



Hi Shane, try turning the ‘road feel’ setting on, biking a minute, then restarting Zwift. I think it didn’t work for me until restarting the software.

Hi I my setting function has no option for road feel on and off… The last entry is workout pain effect