Impossible to disable Tack Neo "Road feel" feature

Hi,

I’ve just bought a Tacx Neo 2T, great product, but depending on when I ride I would like to disable the “road feel” feature and maintain good relationship with my neighbours.

I’ve been setting this at 0% under the Tacx application, and despite this the feature remains fully active while riding on zwift. And yes I’ve turned it off and on again several times.

From a google research it looks like some have been able to turn it off quite easily.

Has someone experienced this ? Any thoughts ?

Many thanks

You need to turn it off within Zwift not within the Tacx app. Once in game go to settings where you can change trainer difficulty etc. there will be a line for road feel where you can turn it off.

I’d post screen shots but not at home and the option doesn’t show up unless a Neo is paired in Zwift.

2 Likes

Thank you very much for your prompt and accurate answer, I just found it on the parameter menu
Have a great day !