Tacx Neo 2T power & Bluetooth lights not working

Tacx Neo 2T plugged it in tonght to have a ride but not happening, no power / bluetooth lights on the trainer along with a fan continually running. have tried diconectiing leaving for over an hour, turned Bluetooth of for zwift and put on for Tacx utilities app but no joy the fan still going when plugged back in and lights still not on / working anyone had the same issue on here and what was the resolution?

Regards
Tony

You need to contact Tacx/Garmin support.

I have the tacx neo 2t and haven’t had that problem. I would also contact support if I were you.

Same here with the Neo 2t on Apple TV. It’s been crazy bad since last updates from last Friday. :frowning: :frowning: Not sure it’s a Tacx problem though…

However I was trying to connect to Apple TV via the companion app. No go. Tried directly on the iPhone and wasn’t a problem. As I suspected, it’s not a Tacx problem. My money’s on the ZC app.

Hi did you able to aolve your issue? i just got exactly same issue. While riding, suddenly resistance went dead, no lights and just fan whirring.

It’s dead, you need a warranty replacement. If you’re no longer under warranty, there are various folks that will repair it for you for a lot less than Garmin.

This was my life last night with a neo 1. Turned it all on and whirring power for the fan but no Bluetooth - I only realised about a minute in on a small hill that felt way too easy. Read all the replies around the web saying it’s dead, but then thought I’d try it through my iMac and the ant+ Dongle I have incase it was a Bluetooth issue (usually use an iPad).

All connected up on ant +, so I unplugged and used the iPad. All fine and Bluetooth working as it should be. So, for me, connecting to ant+, disconnecting and then trying with Bluetooth again fixed it and I got my ride in. Seems to be a lot of issues with this of late!