Tacx Bushido no rpm


(Kurt Van Der Heyden) #1

Hi, my setup is a Tacx Bushido Smart and Zwift on IOS ipad pro.

after 3 weeks of training without any problems, today suddenly in the middle of a ride my rpm dropped to 0. The powermeter is still showing wattage. I`ve tried repairing and even rebooting my Ipad, but the rpm stays at 0.

In the Tacx cycling app it shows rpm so I am sure that the Bushido us working fine.

Any ideas what could be wrong ?


(Kyle MacFarlane) #2

I have this problem as well over Bluetooth. Reported it to Zwift 2+ years ago and they never got anywhere. This is what I did discover with testing:

  1. The problem doesn’t occur with ANT+.

  2. But on Bluetooth it happens with both iOS and Android.

  3. Usually seems to happen after 90-120 minutes of constant riding.

  4. If you unpair and repair everything the cadence will be fixed but gradient adjustments won’t work. Then if you unpair and repair again gradients will work but cadence will be broken. And so on.

  5. Restarting Zwift, Windows, iOS, Android, etc doesn’t make the problem go away. You have to let the Bushido sit for a couple hours.

  6. All other apps work fine - including the diagnostic stuff in the Tacx Utility.

  7. Tacx support blames Zwift.

 

My guess:

Considering the 90-120 minutes it takes to manifest I think it’s probably a rollover that Zwift isn’t taking into account properly. Letting the Bushido sit for long enough allows it to fully power off and so the rollover is reset. Something I never got round to testing is if unscrewing the Bushido and unplugging the control unit would instantly fix the problem or not.


(Paul Graham) #3

Strange the cadence should cut out mid ride Kurt. That said, cadence broadcast from the power unit has had its problems.

If you don’t get any joy in resetting or from the Tacx people, I’d recommend installing a separate cadence sensor. In fact, for accuracy I’d recommend a separate cadence sensor anyhow.


(Johnny Enemark) #4

Same problem here. I keep my rides to under an hour and have had several issues with the cadence dropping to 0. Not launching the companion app seems to rectify the issue but I will admit the issue is sporadic. Hopefully Zwift and Tacx can solve this issue together.


(Agy 978) #5

Same problem here, and I only ride maybe 15 mins. And next day I try still no cadence but power / speed normal.