Super height speed or no watts at all


(Filip Winiarski) #1

Hi,

I am using Elite qubo digital smart b+ with Zwift companion app to connect to a PC. Last year I’ve been riding zwift with no problems. This year I can not make it work.

The trainer works fine, I have tested it with both Elite training app and Zwift mobile app (the game) - it shows correct wattage, speed and cadance. However when I’m trying to connect to Zwift on PC via Zwift companion app and bluetooth it either shows no watts at all or insane speeds of 200mph+ depending on which trainer model I choose in configuration. One good thing is that it shows good cadance. I have tried selecting different models including “other trainer” - same story everytime, crazy data.

Am I doing something wrong? All the tricks with rebooting/restarting/reconnecting/reinstalling done. I spent 3 hours on it :slight_smile:

My setup:

  • Windows 10 Education (version 1709, OS build 16299.611)
  • Samsung 8+ (latest Android)
  • ELITE Qubo Digital Smart B+
  • Latest version of Zwift PC
  • Latest version of Zwift Companion app

(David K) #2

I’m noticing a few differences in how you used to pair and how you’ve been pairing your Qubo recently. It looks like you’ve been pairing your Qubo as speed and cadence, but it is a smart trainer, so you should be able to pair as a power source and a controllable.

Selecting a Zpower classic trainer in Zwift when you have a smart trainer can affect your sensor readings. I’d recommend uninstalling and reinstalling Zwift on your Android to clear the classic trainer information you’ve added in testing.

After reinstalling, try pairing as just a Power Source and Controllable in Zwift and please let me know if you’re still noticing inaccuracies. If that’s the case, while paired as power and controllable, you should be able to complete a new calibration from Zwift’s Paired Devices screen by tapping the wrench icon near to your power source.

If you still notice inaccuracies afterward, or if the calibration fails, try an official calibration in Elite’s support app, but if even that won’t improve accuracy, please open a support ticket with us and we’ll be happy to continue helping you troubleshoot!


(Filip Winiarski) #3

I have uninstalled Zwift everywhere (mobile companion and game app, as well as desktop one), reinstalled and still my trainer only shows up in the Speed Sensor/Cadence/Controllable tabs. Though it works perfect with myETraining app by ELITE, showing proper speeds/watts. At this point, since it used to work properly last winter with Zwift, I am assuming that the problem is on Zwift’s side. Doesn’t seem like my trainer is broken since it works perfectly with ELITE training app.


(Steven D) #4

Hi Filip,

The system preferences file sometimes becomes cluttered with conflicting, inaccurate, or irrelevant data. We’ve had some measure of success resolving resistance and/or wattage problems by having Zwift members delete the prefs file.

  1. Exit and close Zwift.
  2. Open the Documents–>Zwift folder on your computer and delete the file named prefs.xml and also delete knowndevices.xml.
  3. Launch Zwift again, try a ride, and see if that helps.
  • NOTE: After deleting the prefs.xml file, you will have to pair your devices and sensors again, as if for the first time.

  • I’d also highly recommend that you review our Zwift Support KB article entitled, “Setting Up an Elite Smart Trainer”. This is important to ensure that you are pairing your smart trainer correctly to the game.

  • You’ll see in the article that you should pair a smart trainer under ‘POWER SOURCE’ and ‘CONTROLLABLE’. Pairing under ‘SPEED SENSOR’ is typically reserved for classic (non-smart) trainer setups that use speed and cadence sensors to propel the avatar forward in Zwift, so don’t pick that.

Give those things a try and let me know how it goes!


(Filip Winiarski) #5

Hello Steven,

I followed all of your steps and tips. It does not show under Power Source tab, same behaviour. I do one thing differently from the “Setting Up an Elite Smart Trainer” steps - instead of Ant+ dongle connected to a PC I am using Samsung 8 with Zwift Companion app, maybe that’s the case? It used to work this way though :frowning:


(Raf Maesen) #6

I was wondering if you came to a solution because I have almost exactly the same problem as you describe. Only minor difference is that I also have major wattage.


(Filip Winiarski) #7

@Raf77 Yes, I forgot to notice the watts, I also have super high wattage - I did all the achievements :slight_smile:


(Raf Maesen) #8

So you still haven’t found a solution?


(Filip Winiarski) #9

I have not. We need to send the logs from Zwift to their support team, hope it helps :slight_smile:


(Raf Maesen) #10

And if you only pair your phone with Zwift, does that work?


(Filip Winiarski) #11

If I remember well it does work with Zwift on a phone (Zwift the game, completely skipping my PC). It also does work like a charm with Elite training app. I believe this must be an issue on Zwift Windows (I haven’t tested the app on a mac). I might try it on Apple TV. It used to work on PC last year though :frowning:


(Raf Maesen) #12

Tomorrow I’ll try some different setups and I also send a mail to Elite. With the elite app, everything works like a charm.