Stutter every 2 seconds

Hi,

I’ve had this really minor issue for a long time now and want to try and sort it out. When I watch Zwift without connecting my trainer ie I select just watch, the game is super smooth. But when I connect to my trainer the gameplay develops this minor but noticeable millisecond pause every couple of seconds.

I also get it when playing another platform, but I don’t get with other games like forza horizon.

Any ideas? It seems to be caused by the trainer communication.

For info I’m running an Intel Xeon processor with gtx 1080 GPU.

Appreciate your help.
Garry

Hi @Twissy
Stutters might indicate some network lag, either between the trainer and computer, or with the WiFi signal and possibly the internet service to your building.

I took the liberty of looking at what our server logged from today’s (Dec 23) session, and noticed some odd behavior.

  1. There are 9 separate login/ logouts starting at 10:59am UTC to 18:20pm. Most of them last only a couple of minutes (as though you were just testing something out), but two of them are long enough that you were actually riding. These short login/logouts that lasted a few minutes - was that intentional? If not, you may have network connectivity issues: either with the WiFi inside your home, or possibly with the internet connection to your ISP.

  2. Of those two sessions that lasted long enough to be actual rides
    A. During the morning session: your ANT USB stick was connected, and also the Kickr’s power, cadence, controllable and heart rate sensors

B. During the evening session, your ANT USB stick was connected, also your Kickr’s power and controllable. But no heart rate or cadence sensor was connected. Was that an intentional choice? If no, it might indicate a problem with your ANT+ signal between your trainer and your PC.

Tell us which ANT USB stick you have?

We have a couple of articles on support.zwift.com that cover some troubleshooting steps with ANT+.
Issues with Zwift Finding your USB ANT dongle
BLE vs ANT+ Interference Troubleshooting Steps

Thanks for the reply.

I did successfully do a workout today for an hour, but I have been having problems with my ant plus dongle (it’s a garmin one that I have had for quite a few years). I have ordered a new one which comes tomorrow so will test that one out.

I am using a cloud service shadow.tech as my PC which is cat 7 connected to my broadband at 200mb download and 25mb upload, connected to a data centre that has 1gb speeds. I have no issues playing forza/fifa with this connection.

I have been having similar problems with another platform today so I was jumping in and out of Zwift to test things.

I will try again with the new dongle tomorrow and report back. Thanks again :+1:t3:
Garry

@Twissy
Sounds very much like the ANT+ dongle is the suspect then. Would you report back and let us know how the new dongle works out?

Other users have told us that placement of the ANT USB dongle makes a difference. If it’s a corded one, the closer you can get it to your computer, the better. If it’s not corded, then having a clear line of sight seems to matter.

Hi @shooj. I tried the new dongle but it’s the same. No change and the stuttering is still there. Have a look at this video. It’s minor but noticeable. Any ideas?

https://1drv.ms/v/s!AvQNyffQB8NZgZ9aiYGk6_4X_JHKtA

@shooj
So it looks like he has something to do with communication to my kickr as a controllable trainer. When I pair it as a power source only there is no stuttering and I can ride no problem apart from no resistance feedback. As soon as I pair it as a controllable trainer the stuttering is back.

Does this indicate anything??

Thanks
Garry

@Twissy
Thanks for taking time to upload the video. I didn’t notice the stuttering at first, but it’s noticeable if you’re looking for it. I can imagine that gets annoying after a while.

Interesting that this goes away if you connect as power source only. It should not matter if you connect as a controllable trainer. We may need to pursue this lead.

I don’t advocate updating firmware on trainers if everything is working ok. Yours isn’t having showstopper problems, but it’s enough of a problem that it might be worth checking if Wahoo has an update for it. Have you already done that?

@shooj
My trainer is all up to date with the latest firmware. However an interesting find (after a suggestion on FB), not only does it work fine as a power source only, it works perfectly when choosing the plain version (ie not FEC) as a controllable. Switching to FEC as a controllable and the stuttering is back.

I feel like it’s getting close but no idea what that means!? :joy:

Lack of resistance control is a bigger problem than this stutter, innit?

Let’s step back a sec. Does your computer have Bluetooth LE capability, or is the lack of built-in BLE
capability the reason you use an ANT dongle? What happens when you connect everything via BLE?

BLE isn’t an option at the moment hence needing to use ant plus. I don’t know what the difference is between FEC and non FEC?? And why FEC would cause a problem…

@Twissy
So I’m unclear: can the game control trainer resistance using your latest connection setup?

DC Rainmaker’s intro to ANT+ FE-C is a good place to start, but keep in mind this article is a few years old.

I have no idea if or why FE-C would have any impact on your GPU’s ability to render video frames.

Garry have you tried putting your log file in Zwiftalizer.com?

Try lowering your resolution, you have a good gpu but I think your CPU and MB is you bottle neck.

I have Gerrie, failure rates are less then 4% and zero dropouts. I am using a 1440p gaming monitor at 144hz, do you think that could be a problem?

It’s now isolated to the controllable trainer being on FEC as the problem, selecting non FEC and it all works fine. I’m now going to test that on a full ride to see if I get any dropouts. If not then I’m happy but if there is I need to figure out why FEC is the problem. :+1:t3:

1 Like

@Twissy
Just curious - is this a repurposed video edit or CAD workstation from about 5 years ago? You may want to check the clock rate on your Xeon (looks like this is the one you have}

Zwift will default to whatever your monitor’s refresh rate is set to as long as your CPU and GPU can keep up. 144Hz should be possible @ 1080 if the CPU is fast enough, and resolution isn’t set super high (i.e. 4k is too high @144Hz).

That said, Zwift runs happily on lesser hardware than yours. Unlike FPS games, you don’t gain as much by running at 144Hz.

Asssuming that you’re not using gsync, check and mess around with this setting, and see what might work better for Zwift.

1 Like

I have no control over the cpu as I stream from the hardware (it’s like Stadia but a Windows machine).

When you say resolution isn’t set super high are you talking in Zwift or the Nvidia control panel.

I think the issue is a communication thing having isolated it to FEC on the Controllable. Maybe a firewall issue?