Stryd (Bluetooth) and Windows 10 wont pair

Hi guys,

I would LOVE to run Zwift on my PC (Windows 10) instead of running it on my iPhone 7Plus (a bigger screen would nice).

My PC recognizes my Stryd footpod (paired in the bluetooth settings of my computer), and I made sure my iPhone’s Bluetooth and all apps are closed.

But when I run the Zwift app on my PC, it keeps searching instead of simply pairing with Stryd (which is already paired with the computer and standing right next to it!).

What am I doing wrong? How exactly could I achieve what I am trying to?

Thanks for your help


You would need to use the Zwift Mobile Link to bridge the Bluetooth signal to the PC or get an ANT+ dongle in your PC. Make sure that the Stryd is not connected to any other device or app before trying to connect it to Zwift.

You cannot connect Bluetooth device directly to a PC for use with Zwift.

Hi Kim

My understanding is Zwift as yet cannot pair with the Bluetooth component of the Windows PC.

Assuming your PC and the iPhone are on the same network:

You will need to load the Zwift Mobile Link, ZML, on your iPhone, that will then become a bridge over the network enabling the PC, via your router, to read the data from the iPhone.

The ZML and your PC app must have the same log-in name password.

Check to make sure no other Bluetooth apps on the iPhone can ‘steal’ the connection.

I think I need a real step by step guide here!

I have downloaded Zwift Mobile. My PC and iphone are connected to the same WIFI network. I make sure that Bluetooth is ON in my iPhone and OFF in my computer. I launch ZwiftMobile and connect to my account. Then I open the Zwift app ON MY COMPUTER, but it still doesn’t work.

Do I need to run both ZwiftMobile AND Zwift on my phone + Zwift on the computer?

Do I need to to have Bluetooth on only on my phone?

Will I be controlling the app from my computer or from my phone?

Geez, I really need help here. A step by step tutorial would have been nice


1 Like

Here is the KB on the ZML:

 And this:

Also, make sure the Stryd is not connected to any other device or app before opening the ZML. The ZML on your phone will need to be started BEFORE you start the Zwift app on your PC.

Thanks Paul!

Thanks a lot for the links Paul, but I still cant make it work. This is driving me nuts!

I did everything listed in the two links you provided. I can get to the point where the ZML app switches to map view when I launch Zwift on my computer (which I guess is some kind of progress), but then that’s it! The smartphone icon in the upper left shows a yellow exclamation point instead of  “circles”. So I followed the “troubleshooting article” suggested… I allowed the TCP and UDP ports mentioned, I made sure ZML was shut completely, turned on Airplane mode, opened WIFI, launched ZML, then launched Zwift on my computer, but same thing! An exclamation point on the smartphone icon and “searching…” that never ends when I click on “search” for device.


The ZML can be a pain, that’s why for most people I suggest getting an ANT+ dongle in your computer, it will make connecting the Stryd faster and more reliable. 

Here is the one I have in my laptop for connecting my Stryd to Zwift:

For the ZML, make sure you have Bluetooth turned on on your iPhone and the Stryd is not connected to it in any way.

Thanks again Paul for your quick reply!

I wanted to avoid having to buy something else, but if I really cant make it work with ZML, I guess I’ll have no choice but to buy an ANT+ dongle :frowning:

But just to clarify something… If you own a Stryd and an iPhone, you might have noticed that Stryd is paired with any compatible app as long as Bluetooth is turned on on the phone, but that it is not listed in the bluetooth devices. 

In other words, I can make sure that there are no other devices around me with any bluetooth connection opened, I can shut down all the apps on my iphone and I can turn off and on Bluetooth on my phone, but there’s no way I can tell my phone to “forget about the Stryd device” in the Bluetooth settings.

When you turn off the Stryd - and then go into the iPhone Bluetooth settings - Then under ‘My Devices’ do you have the Stryd device listed?

If you do, tap the blue circle with an ‘i’ in the middle at the end of the Stryd ‘not connected’ piece - you will be presented with the option to ‘forget about this device’.

The magic of “shutting down the iPhone and turn it back on” operated!
So i did manage to make it work but the app crashed after I pressed “end run”, so I basically lost all the data I wanted to analyse after my run (and of course it didn’t sync with strava before it crashed…
So I pretty much had it with this ZML, stryd, Zwift trio and decided to go ahead and buy the Ant+ dongle you suggested in one of your previous posts!
Would you say that it’s best to buy the second or the third generation stick? I don’t know if it makes any difference, but I have an iPhone 7 Plus and a PC running Windows 10

I don’t think there is any real difference between gen 2&3, both should work fine. I’m guessing anything that is being sold now should work fine.

Thanks a lot for all your help Paul!
I’ll go ahead and buy the 2nd gen stick
:sunglasses: :pray: