Sterzo not working after zwift update W10

Hi. After latest update of zwift on windows 10 pro the sterzo doesn’t work anymore. I get the message " Hardware Problem. The latest version of zwift is unable to fully communicate with the hardware named STERZO." I use companion to pair my device with my pc.

Do you have any solution?


My Sterzo tested on Android version and works great.

Are you still seeing this issue? Have you been able to use your Sterzo Smart at all?

My zwifting PC running Windows 11 (non-Pro) only received the v1.41 update last night my local time, but I managed to replicate your issue today after various connection attempts. It’s my first time seeing this message following years of using the steerer unit.

The good news is that the message might not be indicative of a deeper issue, as I was still able to use the Sterzo Smart successfully without rebooting Zwift, but only after switching the Sterzo Smart off and on again. You’ll need to remove the screw from the battery cover and briefly remove/install a battery to do this, which is a PITA. The alternative is to wait for the unit to stop communicating of its own accord, which I believe takes between 5 and 15 minutes.
If you’re still having problems, it might be a good idea to use a Bluetooth connection via your PC rather than the Companion bridge.

Here are some further observations, in case they are of use to anyone.
Just to be sure, I did check my steerer’s firmware using the Elite Upgrado app: there have been no changes there for over a year and it’s confirmed as being up to date. And the batteries are good, fresh only about a month ago. I usually get over a year’s use from a standard set of alkalis.

I usually connect to Zwift directly via Bluetooth and hardly ever see a lost connection. I only managed to get this new pop-up to appear after I’d successfully tried the ‘PAIR THROUGH PHONE’ option (the first time in perhaps 18 months), and then hard closed the Companion app on my phone – on purpose – while the Steering connection window was open.

After getting that pop-up and clicking OK, I was still able to pair the Sterzo Smart without any issue (via Bluetooth), but only after powering the unit off and on again. (I installed my own external on/off power switch a while back for various reasons. It certainly comes in handy in this situation.)
When I’d done all this, I noticed that the steering calibration icon had disappeared (just like the bug from v1.39.)

I was still able to start a quick ride with a RoboPacer and use the Steering as usual.

I then exited that ride and exited Zwift. Upon re-starting Zwift, using pairing through Bluetooth, everything was fully back to normal.

I didn’t try the pairing through Companion again, but I’m planning a ride later, so will try to test it to see if that pop-up is generated without me trying to get it to appear.

There’s evidently some buggy behaviour in the pairing screen. I’ve also noticed over the past month that I can consistently make Zwift crash if changing power source selections very quickly on the initial pairing screen. I do hope that Zwift’s developers will be working on making this area more stable.
It’s only the start of the weekend now, so I won’t tag in ZHQ people just yet. :slightly_smiling_face:

As a final aside, I’m curious to know what to “fully” communicate with the Sterzo means. Are there new possibilities being opened up for steering in Zwift, as some have suggested recently? I’m Interested.

Thank you for your answer. It doesn’t work on my pc through phone pairing and i need to add a Bluetooth module to test it again. I tested only on Android to insure that my sterzo works ok.

Putting aside the Sterzo for a moment, when you zwift now in v1.41, does Companion connect fully for you and show the in-game map, etc.? If not, this might suggest the issue is with the device running Companion not establishing or maintaining a network connection with Zwift. There seem to be some other users having recurrent issues around that.
If it’s running okay… I don’t have any other ideas right now. I hope you can sort it out soon.

Companion connects correctly with my other devices only sterzo don’t works. Companion and zwift connects with sterzo and after a while the message appears also the wrench don’t appear. In game all my devices works ok also the steering icon apears next to my name but i can’t steer. Anyway i hope they fix this issue.

I rode for 90 minutes this evening in a busy group, having connected my Sterzo Smart via the Companion bridge. There were zero disconnections or problems and the steering worked perfectly.
Here’s my pairing screen at the end of the ride:

So far, the only time that I was able to reproduce your issue was when I intentionally broke the connection with Companion yesterday by hard-closing the app (so not a sign of defective behaviour). Unless others come forward with the same issue as you, it is possible that there might be a problem on your side. (I suppose that there are few of us zwifters using a Sterzo Smart and even fewer who also read the Forums, so there’s not a huge pool of potential contributors… but we could expect at least some other people to react on this subject since the update if they were affected.)
Maybe you could try to open a support ticket directly with Zwift to get to the bottom of it and be able to get back to using your steerer again sooner?

@Niku_Bietrich and @Dimitrios_Chomatas
This error message suggests it’s time for fresh batteries. Does it work as expected with new batteries?

Thank you, Shuji. Just FYI: I managed to trigger that message once only, despite multiple attempts, by hard closing the ZC app on my phone while using the ZC bridge for the Sterzo, all while trying to reproduce the OP’s issue.

Edit: Just for clarification, my steering has been working perfectly. No issues.

The batteries are new. I’ll try to tested again next week because i’m out.

1 Like

I tested today with the latest update on Win 10 pro with companion and works great. I had some disconnections with my hardware on companion so i tried to use my BT dongle on my pc. The issue remains with BT dongle.

1 Like