Speed readings to high on Elite Power Mag Smart B+

HI,

I have Elite Power Mag Smart B+ with 30mm diameter roller unit and 8 level manual shifter, which I connect via Bluetooth on my Android Tab (Galxy A7).

When I pair with Zwift, it recognizes my trainer as EliteTrainer 18 in Power Source, Cadence and Controllable fields.

Everything works fine, accept the speed readings while I ride. Speed is much higher than normal (like almost doubled). Power readings seem OK, comparing them to the readings that I get from MyEtraining app with the approximately same rpm, resistance level set on manual shifter and gear set on bicycle (I didn’t run both apps simultaneously).

I also tried my trainer with the Garmin Vivoactive 3 watch which found Sp/Cad 20562 and Sp/Cad EliteTrainer sensors as sensors active on my trainer while pedaling. Speed readings on Garmin watch and MyEtraining app correspond absolutely (I run them simultaneously).

Since the power readings on Zwift seem OK, I tried to unpair Controllable, but the speed readings stay wrong. I also tried different combinations – like pairing only Controllable, pairing Power and Cadence without Controllable, etc. but nothing worked.

While I ride, and Zwift slope changes dramatically, (like to 12%), speed falls down.

It is looks like Zwift changes speed according to the slope, but, since I have manual shifter, resistance on my bike is not being changed by Zwift.

It could also be that Zwift calculates speed for my trainer as it has 45mm roller unit. I had to set circumference value in Garmin watch to 94mm (which corresponds to the 30mm radius) to get realistic speed readings on Garmin watch.

How to solve this? I would like to see Power, speed and cadence readings in Zwift in realistic values (presumably without the influence of slope in Zwift).

Thanks in advance

Is this the trainer you have?

https://zwiftinsider.com/smart-trainer/elite-qubo-power-mag-smart-b/

1 Like

Yes, that’s the one

This will give you more information.

Thank you Gerrie

When you pair the trainer does Zwift indicate what level to put the magnetic resistance at? I believe it should, and you will need to leave it at that level for the entire ride. Use your gears to add or reduce resistance.

Thank you for your response again Mike,

No, Zwift doesn’t indicate the level for the manual shifter, but I red somewhere that level should be the same for the whole ride and that best for this model is to keep in on level 3.

So I tried to ride on 3, but also on other levels and still readings are wrong.

Readings for the power on Zwift and on MyETraining are the same for level 3. But speed for some 230 W and my 75 kg and 173 cm are 12-13 km/h on Garmin and MyETraining, and on Zwift speed is around 35 km/h (which varies depending on slope changes in Zwift).

You cannot compare your Zwift in-game speed to other apps like Garmin. See post the @Gerrie_Delport_ODZ posted ealier.

Well, OK, but is it realistic that I go 35 km/h on flat surface with bike on the middle gear (chain on the middle chain ring on front cassette (3 chain rings), and on middle chain ring on rear cassette (8 chain rings)) with some 65 rpm and my 75 kg?

In real world it is too fast. I can’t go that fast pedalling down the hill! :grinning:

That depends on your watts.

Zwift speed can be very slightly high, but overall it is accurate.

Do you have the same equipment in the real world as in Zwift? There are other variables that can make you faster in Zwift also, like drafting.

Please read the link.

Yes, I have the same equipment on Zwift and in the real world, I didn’t use drafting and I develop some 230 W according to Zwift and according to MyETraining app on a circumstances given above. Garmin watch doesn’t have the Power readings.

Paul, if you have in mind link that Garry sent me “How Zwift determine my speed” I red it and it was very helpful. I figured that Zwift determines (calculates) speed according to the wats sent from my trainer. It just doesn’t calculate it right, and I’m starting to belive that it calculates it for 45mm roller unit instead for that of 30mm that I have.

I believe you can set your wheel circumference in this app, also Elite has the Upgrado app to update the firmware, make sure you are on the latest version and do a calibration or spin down.

2 Likes

did you check that you entered your weight and height correct. not 75lb instead of 75kg

1 Like

:grin:
Yes that’s O. I switched to Metrics

Thank you Mike. The Upgrade app could be the solution. :grinning:
Unfortunately MyETraining app doesn’t have the option for setting the wheel circumstance. :frowning: