Speed inacurate with Tackx bushido


(Joachim Verpoort) #1

 Hello

i have an Tacxk Bushido that i have calibrated and connecte in Zwift buth my speed is’n accurate.It goes very slow even if i push hard and fast…

any tips?


(Paul Allen) #2

More info would be helpful.

What are the watts at that time?

Are you going up an incline within Zwift?

Zwift speed is determined by watts, your weight, in game bike used, in game drafting and virtual elevation changes.


(David K) #3

It looks like this is a Tacx Bushido paired over ANT+ to a Windows 8 PC. Pairings are correct as Power, Controllable, and Cadence. 

Before setting up your Bushido, did you remember to pair it within Tacx’s official support software to apply firmware updates? If you haven’t done that already, please do - and while you’re using their software, you may want to complete a calibration outside of Zwift - but remember to unpair your Bushido from their support app afterward and ensure their app isn’t running in the background while you’re using Zwift.

Once your Bushido is paired within Zwift as Power and Controllable, try not to complete a new calibration under Zwift - instead try a ride or two. If your speed still seems inaccurate, I’d recommend checking your Trainer Difficulty settings in Zwift and checking your wheel/roller contact just to make sure you’re not experiencing tire slippage.

If that doesn’t seem to help, please let us know.


(Joachim Verpoort) #4

Ik have already update the tackx rollerband calibrated it and my pc had Windows 10. So my watt was around 130, flat rode and i was riding 24 kph.
Is this normal


(Joachim Verpoort) #5

Seems like the problem is solved. In my profile my weight was incorrect…