Speed correct in pairing but not when riding in app

My ANT speed censor shows correctly in the Pairing window but once I return to riding is shows WAY lower, like showing 3mph when doing 20mph. I understand Zwift speed is calculated from watts but why so far off from what it clearly sees from the sensor?
Makes the app essentially unusable as I end up trolling along the roadside at a walking pace.
Can I try entering a way different wheel size? Any suggestions?

Hi @Frank_Kubin

Welcome to the forum.

What trainer are you using and how do you pair the sensors?

The speed on the pairing screen is with no resistance it is only wheel speed, in-game the speed is calculated from power.

Using a dumb-roller. Connected only via ANT Speed/Cadence/HeartRate.
I DO have a power meter I’m not using right now. Would it help if I hook that up? Also ANT.

A power meter will give you more accurate power numbers so yes it will be better.

1 Like

It sounds like maybe you don’t have the right trainer selected, or Zwift’s info about that trainer’s power curve is messed up. The speed sensor only knows how fast the wheel is spinning–as Gerrie said, that’s what shows up in pairing. But when you tell Zwift what your trainer model is, Zwift uses that speed information to determine what your wattage is (different trainers will be at different watts at different speeds). So it sounds like something is getting messed up in the translation of the wheel speed to what Zwift thinks you’re doing in watts.

But also as Gerrie mentioned, your power meter should solve the problem. You may find that you’ll have to fine tune how hard you’re cranking down the tensioner on your trainer to make it comfortable once you get your power numbers, but that should do it for you.

Using a Feedback Sports Omnium roller unit. Doesn’t appear on the Zwift list of trainers so I select the unknown roller option at the end of the list.

It will be a lot better if you use your power meter.

I ride everyday with a friend that use rollers and a power meter.

1 Like

Upgraded from PowerPod to AroFly and it works fine now.

having read about the AroFly i doubt that very much!