Speed and cadence sensor not working at the same time

I have a speed and cadence sensor, they both work separately. When I connect speed sensor only it works. When I connect cadence only it works.

But when I connect both, it does not seem to work, both device shows connected but not working properly, sometimes says connection lost or just not reading anything at all.

Also when both connected, after a few connect/disconnect one will work but not the other. If the speed works, cadence will not work vice versa.

I’ve tried on both windows 10 and android.

You are probably connecting over BLE and your getting a signal mix up. Try using Ant+? That usually works.

Yes I am using Bluetooth, sadly I don’t have ant+ on my PC.

It’s really cheap it’s just a usb thingy that you plug in your pc or laptop. Research it should work.

Good luck

There’s a few posts on this phenomenon already (assuming this is a garmin sensor). Have a search on the forums and “vote up” the ones that are similar to yours.

Saw a few similar issue. But they are not resolved as well.

Same problem here: Garmin Speed 2 sensors, both connected, only one is working at the same time.
Identical configuration with another App works without problem showing speed and cadence data.
Below my answer in another thread in this forum.


Yo llevo dos días en Zwift y me ocurre eso.
Uso sensores de velocidad y cadencia Garmin Speed 2.
Antes de la actividad los encuentra perfectamente e indica “Conectado”. Si el último que configuro es el de velocidad, éste funciona correctamente y el de cadencia no. Si el último es el de cadencia, al contrario. No marca velocidad y sí cadencia, pero entonces el Avatar no avanza.
Por tanto dejo funcionando velocidad, y cadencia conectado.
Durante la actividad veo velocidad (y potencia, por lo que avanzo) pero cadencia se muestra “–”, pero en Companyon indica siempre 60-64rpms… Aunque esté pedaleando a 90rpms.
Y es cosa de Zwift, porque en el Suunto o el Polar veo bien la cadencia, y en otras Apps muestra velocidad y cadencia perfectamente.

I think I have the same problem too, Mike. I can’t get my Garmin Speed and Cadence sensors 2 to work via BT with my Mac nor my iPhone 11. I am beginning to think it might either be the sensors themselves or the IOS software. I tried using the app RWGPS on my iPhone 11 and the sensors and it does the same thing. I can pair both sensors super easy. It picks up the cadence sensor just fine but my speed is still 0 mph, just like in Zwift. It pairs but does not transmit data. Unfortunately, I don’t have a Garmin head unit to test them out at the same time.

I may end up trying the Wahoo speed and cadence sensors via BT. Has anyone had any luck with them or similar issues to Garmin?

I’m having this same issue with my whaoo sensors unfortunately. I’ve gotten it to work twice but cannot for the life of me figure out how. I am using bt though so maybe I’ll try ant.