settings on zwift to pair my elite rampa

I have a elite rampa. I succeeded only once to pair it properly with Zwift. All the other times I couldn’t feel the resistance changing when I went up hill.

When you pair the rampa, you can choose; elite power, elite rm, elite trainer, elite this and that. Witch settings do I choose to pair properly and why isn’t my resistance changing?

Please help  me out.

Hi Aad,

How do you connect to Zwift? Are you using BT or ANT+?

Check this video on Youtube:

Thanks Bastiaan. Ik have watched it several times. I even freeze framed it to watch the settings but it didn’t help. I am using ant+. And I have a perfect connection but the resistance doesn’t change whilst cycling on Zwift. I only managed once to succeed on a resistance changing connection.

In the video the trainer is paired as Elite PWR as power source. The same for cadence. 

Sounds to me that ERG mode doesn’t work all the time for your trainer.

You should raise an official support request:

Hi Aad, I have an Elite Rampa too and have experienced the same issue, I also find that I have too get cadence up to 130 just to hit 300w. Have you managed to resolve the problem ? 


Hai Paul, when I use the fec connection everything works properly. It reacts directly to changes in angles etc. I don’t need to hit 130 rpm to hit 300watt. I think that the everage 180w that I achieved is realistic and that’s my reference. I connected to my iPhone via the rm setting and that was less realistic. The resistance was significantly different and the cadence got frequently lost. So I prefer the ant connection with the fec setting and think it’s quite realistic.

Thanks Aad, that seems to have done the trick. I’m sure I’d have got the eventually but that’s been really helpful.

I have a RAMPA as well. I have an iPhone 5s with apple adaptors and wahoo ANT+. This works fine with sufferfest.

Swift doesn’t ‘find’ the ‘controllable trainer’ but it does find the cadence source (I have no other other power/cadence sensors). Swift also finds my HR monitor ok.

Any suggestions please -as currently I can only log in and watch from the side of the road rather than ‘RIDE ON’


Ian. With Ant you need to use all the devices (trainer, cadence) in the FEC connection. On your iPhone you can connect via Bluetooth and then connect all the divices at RM. Before you do that you have to reset your rampa by unplugging it.

Thanks - I had turned off BT from my phone already, as i know its an issue sometimes having both. What’s RM? I’ll try with BT rather than ANT+

I can connect via bluetooth, and get resistance changes as zwift sees the rampa as a ‘controllable’


But with ANT+ the RAMPA only gets recognised as power source, but IS NOT controllable. I then have to change gears!

Any ideas?..

The RAMPA is not listed as a supported trainer?

Which settings do you use?

with mac and ant dongle - connects via ant - fec ok

That’s indeed the right setting for ant+. Well I suppose you need to use the Bluetooth setting then. Can’t help you out with the fec / ant+ setting. May be elite can.

I can now connect rampa via BT and ANT+. It’s switching between the two that is hard, I have to switch the rampa off in-between.

BT seems more ‘reliable’ than ANT+, even on Macbook air.

Now to work more on the resistance issues…

If you want to change between BT en ant+ you have to switch off the rampa. Zwift has an update for iOS maybe that will help too

I also have issues with my ramp.

in the beginning everything worked fine . now it doesn’t connect with BT anymore. no idea why… i bought ant ANT+ and it does connect but the wats don’t change automatically anymore. I feel no difference in uphill or downhill… can someone help me out?