Elite Rampa - Not Enough Resistance

Hi, I am suddenly finding that I have not enough resistance in Zwift. I am using an Elite Rampa trainer on a Windows 8 PC. I am using an iPhone 5 with Zwift Companion to connect via Bluetooth - App is up to date.

I had this set up in July and all was fine. But I logged on last week and now my problem is that I am spinning out in my highest gear on the bike and doing probably 140rpm cadence and max 330 watts.

However, the power feels correct compared to the effort I am putting in.

I have been using the Elite MyTraining app as I had been previously and everything was as it used to be, no problems.

I have tried all of the Zwift settings but to no avail. In Workout mode, changing the Incline setting seems to work, but that setting does not exist in normal Ride mode, or in races.

If anyone has any suggestions, I’d appreciate it.



Did you pair the trainer as power source and Controllable.

Make sure the trainer is not connected to any other devices, close all apps that may connect to the trainer.

1 Like

Thanks Gerrie. Nothing has changed since using the set up last time, but I will check for any other connections. There is no other training app on the iPhone and the trainer is not connected to the laptop.

I have been searching for a solution myself. What you have described is exactly what has happened to me in the last week. Resistance has been reduced and I am spinning madly. Did you come up with a solution??

Hi Rick, I should have updated this. Yes, I moved from Bluetooth to Ant+ and it works fine. When I am going full gas I am in almost the highest gear on my bike but it’s fine. Hopefully it works for you if you’re not using Ant+ already.