Scheduled races not starting

I am scheduling races to join on the iOS app and see the I am “going” on the Apple TV app.  I start a ride and I am never prompted to join the ride.  This has occurred 3x’s in a row now.  Once on 12/20 and twice tonight for 1835 and 1910.

I have force quit the Apple TV app and restarted the AppleTV to try and see if that would fix and it has not.

1 Like

I have the same issue too connecting via Apple TV 4k.  They day before I couldn’t join a race.  Yesterday I managed to join one.  But today I couldn’t join any events.  It will say I am going but doesn’t prompt me to go to the staging area after I get onto the road.

1 Like

I have the same problem but using a PC laptop. Support is trying to help me but no answers so far. They thought it was my firewall but I turned it off. Still no luck. Waiting for their next suggestion.

1 Like

Same problem here. I’m on the road from my iPad 2. Getting no teleporting to the events. Last months it worked out. Not today

1 Like

Same problem. I’m using an Apple TV 4th gen.

Still no call to the events that i have joined. Is there an other way (apart from an automatically call) to get directly into the race?

Via iPad mini i magaged to join a race but without any other riders. So i quit. In watopia without event i also don’t see at other riders.

Connected via Apple TV and unable to join any events.  Also, I was not able to see any other riders.  Is there a fix coming out?

Same story for me using a AppleTV 4th generation … very frustrating !

I was able to fix the issue of not seeing other riders and not being able to join events by force quitting the Zwift app and reopening it.  Instructions below.  

  1. Press the Home button to return to the Home screen of your Apple TV.
  2. Double-press the Home button to enter multitasking mode. 
  3. Swipe left or right to select the app in question.
  4. Swipe up to force quit the app.

I note Shane Rieger tried the above but didn’t work for him.  Since it’s worked for me, have a go at force quitting first.  

Hi all,

We’ve found an issue where Apple TV does not reconnect to servers after being put to sleep on a WiFi connection. It sounds like this may be causing the issues you are experiencing. If possible, run an ethernet cable straight into the Apple TV. If you continue to have issues, please open a support ticket and we can help!

 

Hi all,

Using an ethernet cable does not solve the problem neither :frowning:

For the moment, the only possibility that works is to restart the Apple TV every time you start an new event. It seems that for some reason the Apple TV has to reconnect the Zwift servers before he shows the “join event” correctly …I received the following message from Zwift on this topic :

This is an issue we are aware of, and we are working on getting a hotfix out as soon as we can. I’m going to put your ticket on-hold until we have a hotfix, or a troubleshooting solution. At that point I’ll reply here. You can also reply to the ticket at any time to bring it out of being on-hold.

Regards
Johan - Belgium 

 

 

Good News Johan, thank you!!!

I had the same problem. I finally got it working by changing the settings on my router’s firewall. I use a PC and Comcast router. Works fine and get teleported to events.

 

Per Zwift tech support:

Your router firewall should allow all incoming/outgoing Zwift TCP traffic on ports 80 and 443 and all Zwift incoming UDP traffic on port 3022.

Hi, 

On my iMac and iPhone, it works perfect and they use the same router specs when I am home. So I think this is a specific Apple TV problem but I am convinced that Awift will fix it on short term because the problem is known.

Regards Johan

 

My problem has been resolved. After signing up for an event and logging in via my Apple TV, I’m getting a prompt to join the event after selecting Ride. 

Hi All,

 

I had this exact problem yesterday. Today it is fixed and I had a simple, clear fix.

 

First up, don’t be afraid to log tickets with Zwift, I have now twice and they are really responsive. I logged a ticket last night before bed, got up this morning and they had asked for logs. After sending them the logs I went through them. It seems the application uses UDP on port 3022. Whilst i had turned off windows firewall through troubleshooting, I know that UDP 3022 is not allowed through my edge (internet facing) firewall / router. I allowed UDP 3022 in through the firewall and retested Zwift. I can now join races as expected. I’ve now tested several times.

 

Perhaps give this a shot if you’re having issues, it worked for me.

 

BTW, i’m using windows PC / laptop, no wireless only ethernet cable. Was able to going events, but never get prompted to join events. This is regardless whether i used the zwift mobile app inconjunction with the PC.

 

I think the key is to ensure that 3022 UDP is functional whether that be on you router or even a local security program / firewall. 

 

Ride on