Saris H3, ATV Bluetooth dropout

I tried to get this flying as a different and separate thread also naming resistance latency. But when the forum moderator looked at my opening post they pushed it in here when there was mention of the H3 in my equipment mix. I really wish they would not have done this as I wanted to see if the issue was broader than just folks with an H3!
I clearly have had some BT drops but the random resistance latency is my biggest issue.

Happened again, Jan. 9, twice tonight. This is now just more annoying than zwift is fun.

I feel your pain Andrew. My Apple TV unit is now a paper weight until I see a update come out that lists addressing these issues. I’ve just gone back to using my PC laptop with no trouble.

Have you opened a support ticket with Zwift?

Hopefully they can reproduce this and get Saris and Apple to look into this, if they can’t fix it themselves.

Yes, I have. The amount of room that Zwift allows in terms of characters to describe the issue, and respond is quite limited. Thus with the limited amount of information to work with they responded with what I would call Level 1 support recommendations. IE: links to basic trouble shooting sections of their website. I tried to shoot an email to the support email address with more information and it kicks back with a we do not do email note. I have had a support request in at Saris now for a week with no response. (shocker) I have called Apple support and the Cliff Notes on that conversation was its up to the App Developers to stay up with us not the other way around. So as a user I’m not sure what else I can do. I see a circular firing squad shaping up. :slight_smile:

I have had the same issue as stated above with the BT dropping out. Very frustrating at least. Checked the Zwift App for updates, checked ATV for updates, moved ATV to within 2 feet of H3 and nothing. So I knew it was not interference. Finally I checked my Firmware on the H3 which was at Version 31.060, there has been two updates since. The current Version is 31.062, after updating the Firmware I have not have had an issue with losing BT connection.

1 Like

Ok, some potential good news. Had a 5hr ride today with no drops. Changed up my approach and thinking this helped.

  1. Turn off BT on phone
  2. Turn on TV
  3. Turn on ATV
  4. Start Zwift
  5. Plug in Saris H3 and connect

So ran without companion and without HR. May try HR tomorrow. No issues at all. I read in another thread that the companion app/phone has BT searching problems where they compete for BT channel (forgive the terminology abuse I’m not a tech guy) and when a signal drops even for a second another app on the phone or ATV grabs the BT spot, causing the trainer to have no more space and thats why it won’t reconnect. Not sure if I made any sense but turning off the BT BEFORE turning on ATV seems to have helped. I’ll update later if I have another issue.

Obviously this is a workaround but at least I can ride and use the trainer.

Just for giggles I thought I would try a ride on APTV this morning. Resistance lagging started right out of the chute.
Backed out of that, fired up PC laptop with BT direct connection and had a perfect ride with everything 2.4 Ghz and Bluetooth blasting away with absolutely no issues.

Thanks everyone, I too have had many problems the last month.
My rider just slows and stops, sometimes I can hop off the trainer disconnect and reconnect the power and it starts working again without losing too much time but for a race I am toast.
I use a Saris H3, 1 year old IPAD, and new iphone xs on bike for zwift companion.
I thought maybe it was the blue tooth wireless ear phones but everything worked all year until about a month ago. I plan to not use those and try the old plug in to phone style with cable for music next ride to see if it helps the drop outs.
I have the latest trainer firmware upgraded last week and the latest ZWIFT and companion versions.
I will continue to check this thread, Thanks.

It’s not the Apple TV. I ride mostly on Apple TV 4K w/Neo. No issues. A buddy is riding on Apple TV 4K w/Kickr and no issues. If it was the Apple TV itself, there would be a lot more complaints here on this forum as well as elsewhere.

It’s something about the Saris. In another thread, someone mentioned they updated the firmware on their Saris which solved their problems.

1 Like

Hi Rob, did you bring your H3 firmware all the to version 31.063? If so you might want to try winding it back one notch to version 31.062. I have had all kinds of crazy stuff happen with the .063 version.
If others have any commentary on this please chime in.

I will check tomorrow, I did upgrade the trainer firmware within the last week or two. I have had more drop outs the last 3 weeks than the whole 11 months prior. Thanks for the info.

Rob

Rob, I got to thinking about things last night and realized that I had not tried the .063 firmware since the last Apple TV OS and Zwift updates. So, I pulled the firmware forward this morning and took it out for spin. All I can do is report results. The ride went well, no resistance latency and no BT drops. Now all that said it is much more likely that this is just one more ■■■■ in a long series of wanks with this issue the last couple months. Compare your software with mine and see if we are running the same versions.
Tomorrow is a rest day for me so I’ll try again Thursday and report results.

Apple TV - Version 14.3 [18K561]
Zwift - 1.0.60639

BTW, I was using the Companion App for mapping with the BT bridging turned off.

Add me to the long list. Setup:
Apple TV
Zwift version 1.0.60639
Saris H3 firmware version 31.063 - connected via BLE to Apple TV
Garmin Dual HRM - connected via BLE to Apple TV
Garmin Edge 520 Plus - connected to Saris H3 via ANT+
Stages crank arm - connected to Garmin Edge 520 Plus via bluetooth
Zwift Companion running on iPad

Since the Zwift version update on 1/5/201, have ridden 6 times on ATV/Zwift/H3.
First 4 rides ranged in duration from 1:00:06 hour to 1:26:45 - no events or races, but did include one workout. Did not drop the connection between ATV and H3 on any of the four rides.

Last two days’ activities were both events (Tour de Zwift). In both cases, the ATV-H3 connection dropped at almost the same time - 40 minutes into the event. In both cases, had to unplug the H3 and plug it back in for ATV/Zwift to find the H3. I also have a Stages crank arm, and ATV/Zwift could find it via BLE before the H3 restart.

Question for those more knowledgable than me: many mention the ATV remote disconnecting at about the same time as the H3 disconnects. I believe that the ATV remote “goes to sleep” if there is inactivity for some period of time. Is it possible that the ATV remote going to sleep after some period of non-use results in the ATV losing the BLE connection and the H3 then not being able to reconnect? I ask because when I ride an event, I tend not to use the ATV remote (relying on Zwift Companion for information). When I am just riding, I tend to use the ATV remote more frequently. I haven’t tested it, but will do so to see if using the ATV remote to keep it from sleeping makes any difference. With regard to the ATV finding the Stages when the H3 disconnected, I note that I had used the ATV remote to try and repair, so that would have “woken up” remote.

The thing is, I can’t recall anyone saying this happens on Apple TV apart from in combination with a Saris H3. I use Apple TV with an Elite trainer and I’ve never lost the ATV remote connection.

Apple TV can go to sleep and the remote will disconnect. However, I have never had that happen during a ride of any duration (e.g., 30min - 4hr) I also never use the remote while riding. You can check in the Apple TV settings to see if there are any power saving or sleep options, but I do not remember having changed any such settings.

I had a look at the Saris firmware update release notes. I noticed that they actually include specific fixes related to Zwift in addition to other bug fixes. Here are a few examples:

* Fixed power dropouts on hills in Zwift.
* Fixed issue where Zwift would sometimes stop on a transition to an uphill.

I have used a Neo1 for years w/out upgrading the firmware. I also have a Kickr1 that has not been upgraded since 2016. They never experience any type of dropouts, resistance issues, etc… My point for mentioning this is that to me this appears to be strictly a Saris issue where they have not implemented something correctly in Bluetooth or otherwise. Then again, maybe everyone else is doing it wrong :man_shrugging:

1 Like

Thanks @Lin_Alan - interesting that the notes from the current firmware version and even the last couple are not on the Saris website. The notes you cite are from versions that are a couple of years old.

Ride report:
This is the follow-up to my initial test of the .063 H3 firmware with the most recent versions of iOS for Apple TV, and Zwift. In short with no surprise, failed. My wife did a ride first thing this morning and got a BT drop about half way through her ride. Then I hopped on a couple hours later and immediately had resistance latency. So, I’m tapping out on Apple TV until something comes around for a fix.

This is what I know to be true and tested in my pain cave.
All with H3 .using .062 Firmware

H3 with Zwift PC version - Works
H3 with Rouvy PC version - Works
H3 with Saris App on iPhone 7 ERG Mode ride - Works

Further, I got my H3 September 2019, I rode all winter last year with Zwift PC, no problems. The only thing new was introducing the Apple TV into the equation late this fall and it has been nothing short of a dumpster fire.

I trained all last year on Apple device + Saris H3 + Zeift and it was perfect. It went wrong in one of the autumn updates.

Infuriating that Zwift are ignoring the issue.

I just bought my H3 and ATV in October 2020, so don’t have a lot of data but I went back to look at all virtual rides.

  1. No dropouts with Rouvy - only Zwift
  2. No dropouts in erg mode on Zwift, even after most recent update
  3. Dropouts started after Zwift VERSION 1.0.58982 and are almost constant after Zwift VERSION 1.0.60239
  4. No dropout with Mac version yesterday

Just noticed that there is a new ATV update as of yesterday: * Apple TV v 1.0.60640 (January 14, 2021)

Will give that a try but not hopeful.