Samsung tab s7 can't connect Bluetooth devices

I bought a new Samsung tab s7 (2020). In the Zwift app I cannot connect to devices including Assioma pedals, Wahoo HRM or Wahoo speed sensor. I can connect all to the TrainerRoad app without any issues. I also can connect headphones ect. to the tablet so I believe the issue is with the Zwift app. I tried uninstalling and reinstalling the app a few times. Turning Bluetooth on/off. Restarting tablet. It still cannot find any of the devices in the Zwift app pairing page.

Any suggestions?
Thanks in advance!

1 Like

A few minutes after posting this topic I found the problem. I had to go to settings on the tablet - location/location request - app permissions - Zwift and set to (allowed only while in use). After that all devices paired immediately.

Hope this helps someone.

5 Likes

Do you have also sound issues with swift on your tab?

1 Like

@Randy_Smallwood 's suggestion helped resolve my Galaxy Tab S7 connection issue, but the sound is distorted during activities as if picking up feedback from the trainer (sounds like an airplane flying low).

I have found a solution. The sound bug is related to Samsung.

You have to open screen recorder, start a capture and pause it immediately. But let it open.

You now have a proper sound until you close the screen recorder.

Not the best solution, maybe I will find a real one.

Cheers

Thank you. Thank you. Thank you.

I’ve tried everything until I saw your comment in brackets…“allow when app is on use”.

I had mine at “all time” and for unknown reasons, that made a difference.