Samsung Galaxy S3 Stages Cadence

Want to let everyone know that with a Samsung Galaxy S3 (SM-T820) I have problems with the cadence. It generally sits at zero during most of the ride- occasionally will spike up, then back to zero. Buletooth on all sensors- Polar HR, Tacx Controllable Trainer, and Stages Power Meter. All other readings are fine- including the power from Stages. But the cadence reading from the Stages is just not working. I do know the reading is fine- when I run the Stages over Bluetooh on a MacBook- it is fine. And with ANT on Windows- all fine too.

This is the only issue I have - app runs fine otherwise on the tablet.

Hi @Tim_Cary

Is it the Stages cadence sensor that looks like a button, or the power meter that also broadcasts cadence? Either way, when’s the last time you replaced the battery? Let’s eliminate a tired $2 battery as a cause.

It is the power meter that also broadcasts cadence. And thank you for the battery- I should have posted that the battery is fresh- within the last month- and I have a full battery indicator on the Stages app.

SM-T820 is the SIII tablet, not the phone from 2012, right? Is it running Android 7.x, or 6.x? We ended support for v6.x starting with last week’s game update.

Assuming it’s Android 7.x or newer, which generation of Stages power meter is it?

If it’s Gen 3, there was a Jan 29 2020 firmware update. Release notes say “magnet-based cadence automatically enabled when a magnet is detected. Resets on sleep.” Not sure this is your issue, but have you updated its firmware to v1.61?

Thanks for the response. It is a tablet- not a phone- and on Android 9. However, the Stages Power Meter is a Gen 1… but at the latest firmware of 2.0.86. I realize the Gen 1 is old. Last FW was March of 2018. If there is anything you can look at to help this issue- then awesome. Like I said- cadence is fine over ANT on a PC and bluetooth on Mac, as well as cadence from it to other training apps like Rouvy. I probably could solve the issue by adding a dedicated cadence sensor of course.

When did this issue start for you? Was the cadence working well previously on your tablet and it all of sudden went wonky?

Or is the tablet the new variable?

This should be considered as a first experience report. Two rides have exhibited this same behavior.

So to clarify: 1) there was never a time that cadence worked correctly with your Galaxy tablet and 2) previously you were Zwifting just fine using the Windows or Mac machines?

FYI: on Friday Feb 14 (the day after your first post), we pushed a patch for Android v1.0.46128. Have you subsequently installed that? Same result?

When you run the app after a reinstall, you should be prompted to grant permissions to Location folder - say yes. In Android OS, an app’s Bluetooth permissions are buried under the Locations folder.

Let’s check all these boxes before we continue. I have not heard of wonky cadence with a Stages power meter + Samsung SIII tablet running Android 9.x so this is puzzling. Have you contacted Stages support about this?

Correct. I did make sure the app was up to date today, and attempted a ride, but have the same problem. I have not bothered to contact Stages, as I don’t see the problem in any other applications, and that gen 1 is way out of warranty.

We might be able to chalk this up to the age of the tablet model. I don’t expect perfection, I just wanted to submit the report since you are still in beta. I wonder if anyone else out there has the same setup as me- same model tablet and a Stages?