Rides not saving nor the logs

Hi. Today I did a soft workout but the app did not save my rides. After that I tried looking at the logs but the last one was yesterday’s. I also did two more short rides but it didn’t save either. So, I reinstalled the application but nothing happened.

Can you define short rides.

2 km plus. That’s short rides, just for testing saving.

Care to elaborate of your setting? Which device is running Zwift?

Thanks for replying. I’m running zwift on windows 10

AFAIK, the minimum distance is 5Km.

Care to try ride further than that?

No need to reinstall…

@B_CN and @Ivan_Morales_Celis_O Rides need to be 2 km (1.24 mi.) or longer and runs must be at least 0.8 km to upload.

1 Like

Just finished a 1.5 hours activity rode 53 km. Ask for saving and nothing happened, logs folder still not move (last one from 21st July). I really don’t know what to do. Please help

Did you see other cyclist/runner on Zwift will you were doing the activity?

You could try uninstalling Zwift and reinstalling to see if that helps.

Can you please elaborate on “nothing”? (pun intended…)

And if you can’t find an “inProgressActivity.fit” in your Documents\Zwift\Activities, then maybe you are looking in the wrong place… What is the directory you look into?

Yep, lots

Nothing means, not activity saved. I’m looking into …Documents\Zwift\Activities and the inProgressActivity.fit is dated July 21st

That’s strange…

Let’s try it another way (maybe the way you tried…): Starting Zwift, the launcher minimizes to the icon notification area. Locate it, right click, and select “Open Logs Folder”. Navigate …\Activities .

Is that directory the same you were looking into?

Hi, I did as yo ask. The logs folder is the same. I also took a screenshot just before trying to save the ride. A pitty it is no possible to upload pics. The only up-to-date files in the folder are those “Launcher_log”

Throwing the towel. May I suggest you get in touch with Zwift support?

The specifics simply don’t add up… I know of no case, nor have I witnessed one, where inProgress.fit file does not exist. The information pieces don’t describe a scenario I can think of… (there are additional ways to explore this issue, but they all fall under “heavy artillery”…)

Sorry… good luck with support!

Did you try uninstalling and reinstalling Zwift?

He did…

1 Like

@Ivan_Morales_Celis_O When you uninstall and re-install Zwift make sure you use the procedure on this link: https://support.zwift.com/en_us/re-installing-zwift-BymCF82TH

Hi Paul, I’m doing it for the second time. Altough I’m almost certain what the problem is. I’ll give feedback as soon as I finished re-installing.

Hi guys, first of all thanks a lot for your help. I finally discover the problem. Past Wednesday I set som e thinks on Windows, among those I blocked Ransomware With Controlled Folder Access, but I did not allow ZwiftApp.exe and ZwiftLauncher.exe to write changes in the ‘Documents’ folder. So, by allowing it problem was solved. Thanks again

2 Likes