Activities won't save / In progress issues

Hello everyone

I’m having trouble saving my activities.
It goes like this:
I start a ride I then save the ride and when I check to see it into my activities feed it won’t appear. ( neither in Strava )
I tried to reopen the app, I tried to start a new ride and do the same normal saving process, I updated my app…
All this didn’t work.

Please, if you know anything about this issue, give me a hand!

Hi @Ov_Lucescu

How far do you ride on these test rides, a ride need to at least 2km to save to Strava.


it’s true i didn’t do the test at least 2 km.
but that;s for strava, the problem is they won’t save in my zwift activities feed .
After I click save ride it won’t appear in my activities ( Zwift app )

@Ov_Lucescu from what I remember Zwift won’t save any ride less than 2km either to prevent clogging up your feed on since the assumption is is that a ride that short was a test of something and not an actual ride.

Try riding for 5km or so and saving and let us know if it saves to both your Zwift feed and Strava.

1 Like