Resistance issues...bike vs. bike?

Long winded post warning!

OK, so I already have a different thread containing some other issues/complaints with my trainer, but this is new, and seems unrelated so…

Pertinent info:
Trainer Saris M2
Running Zwift on Apple TV 4K
My bike 700c Gravel Bike (1.25" Tacx trainer tire)
Wife’s bike 27.5" MTB (1.25" Tacx trainer tire)
Pairing our trainer through our companion apps…Mine is an Android, hers is iOS.

So, the issue.

The wife and I both did a short ride last night, we both did the same route (Watopia - Flat Route).

My wife went first, she warmed up the trainer (10 mins), then did the Saris calibration, then fired up Zwift, and off she went…Seemed OK at first, maybe the first mile or two, but then Zwift (or the trainer) went nuts, basically it “reversed” some of the resistances…ups were easy, downs were hard, and in some cases, nearly impossible for her.

Then I went and did the same thing, Saris calibration, then fired up Zwift and off I went…I had zero issues on the exact same route.

It has done this to her three times now, once last night, and again the last time we rode NYC, and then one solo ride for her (Innsbruckring I think).

Thoughts?

She never use to have these issues, so what changed? The trainer is the same, the Apple TV is the same.

The only difference between us, is the bike size/style (which is why we calibrate before our rides) and the Companion app, Droid vs iOS.

We’ve made sure her gender/height/weight/age settings are correct. and both our companion apps are running the current versions, the Apple TV app is current, and the trainer has the most up to date firmware (checked again last night).

What am I missing?

EDIT: Just noticed the “bugs & support” forum (Sorry Guys)…If one of the Mods/Admins would like to park this thread over there, that would be great. Thanks!!

Quite a few people have posted similar adhoc issues. Saris and Kickrs seem to be the norm (but not only those). And its not necessarily repeatable. For example, I had this happen about 2 years ago and then recently happened a couple of times. Once I fixed it mid-ride with a re-pair. Another time I tried that and no change. And for past 3 weeks, I cant repeat it. Since no-one from Zwift has commented in the posts noting the issue, best you log the issue with support and send your (wife’s) log file too. Good luck.

1 Like

@Dean

Thanks for the reply!

OK, so I’ll sound stupid here but…

Where do I obtain my wife’s “log file” LOL and how do I submit it to support?

I’ve (we’ve) only been Zwifting for a few weeks, so I’m still learning about the system, and have yet to submit any kind of support issues (aside from the couple threads I have on here).

Thanks!

Sorry you can’t get log files from Apple TV

Sorry Dennis. Aaprt from logging the issue direct with Zwift, you could try un-pairing and re-paring the devices. It worked for me once so worth a shot.

1 Like

Is there a reason you are pairing through the companion app and not directly to the Apple TV?

Do you force close the Zwift app on Apple TV after each use (this clears up lots of buggy behavior)?

1 Like

Great…No way to get log files.

Well, we have no other devices to run Zwift on…I’m sure not going to use the tiny screen on my phone for Zwifting, nor am I interested in getting a PC for this so…

Ugggg! This indoor training thing is quickly becoming more trouble than it’s worth…

Stick with it, you will get it working!

I think you should try pairing directly with the Apple TV, forget the companion app, and test it out. Make sure you force close the app first and after each ride.

1 Like

@Mike_Rowe1

I pair using the companion because the Apple TV’s 3 Bluetooth (really only 2 after the remote) device limit makes it tough to pair all of my devices (I have a HR sensor, and I’ve been trying a new cadence sensor as well…yes I know the M2 has cadence built in, but I question it’s accuracy)…the Companion app doesn’t really have a device limit.

And, no I haven’t been force closing the Zwift app, I’ll have to try that.

I’ve had this happen before with my Kickr Core. It was annoying enough that I just quit, trashed ride. Then restarted and repaired trainer. All was good. I think it might just be a random gremlin.

1 Like

True, you will need it for all those devices. I think just to test it out, you should try just the trainer direct to the ATV and see if the behavior continues.

Yeah, we’re going to ride again tomorrow night.

I’ll have her do a direct pair to the Apple TV and see how it goes.

Thanks!

I’ve had similar issues in the last 3-4 days. For me, I’m doing a training plan that requires you to adjust power to the intervals stated power. Thankfully, ERG mode does this for you. However, the power adjustments are lagging behind 30-60 seconds for me. Sometimes longer. This means I can’t stick to the required plan. I posted a response to a similar forum thread called " Erg mode in Build me up plan". Seems you can’t post links to other forum responses, so all i can do is provide a reference to the title of the thread.

Similar to some other responses above, in the thread I responded to, it appears these kinds of issues have been occurring for years. I imagine there are very tricky to troubleshoot given there are so many points of failure. You would almost need to be in the lab with the support team while they monitored your setup. I guess we’ll see. Hopefully my issues goes away. I have 5 workouts this coming week in Build Me Up and they look to alternate intervals often at 30 seconds apart. If ERG is lagging that much I’ll never complete these workouts.

I’m trailing all forums to see if there’s a common theme/thread.

1 Like