Resistance backwards

I’m not sure if anyone else is having this issue, but since the last Zwift Companion update, I have noticed that my resistance is backwards. That is, I have LESS resistance as I ride uphill with MORE resistance as I ride downhill.

I am using a Wahoo KICKR V5, Apple TV, and Zwift Companion for a Bluetooth bridge. I have the latest versions of Zwift and ZC.

Anyone else experiencing these issues?

It’s not much help (sorry) but this sounds like more of a trainer issue than a Zwift one.

First, thank you for your response.

I have to admit that I’m sceptical, however, because my trainer has been working flawlessly until the most recent Zwift Companion update. The most recent ZC update was July 6th, and my issues started immediately after that.

I did go to the Wahoo app to see if there were any firmware updates, but none were showing as needed for my trainer.

I will try unplugging the trainer for a few minutes and “resetting” it to see if this rectifies the issue.

If that is not successful, I may try moving to an earlier version of the ZC app. Again, this is where I believe the issue lies, but I want to try all options individually to attempt to isolate the issue.

Out of curiosity, do you always leave your trainer powered up, even when not in use? I know from reading these Forums that some people do that, but I fail to understand why. Maybe I’m an odd case, but when I finish a session and know I won’t be on the indoor trainer until the next day, I power down all my zwifting equipment via a multi-socket extension cord featuring a power switch. In 3+ years of using a KICKR, I have never had any of the weird behaviour that comes up from time to time on the Forums. I suspect that my utilities bill is lower for it, too.

I’ve had this before on a totally different setup (Windows, ANT+, Neo 2T). I think there’s some protocol communication error when you have the Companion app running, that I’ve documented before. Obviously if you’re bridging for a specific reason like too many devices then you can’t not use the Companion app, but you could try connecting the Kickr directly to the Apple TV to see if it resolves the reversed resistance issue. I bet it does.

I do leave my trainer powered up - honestly, I never thought to do otherwise, although you make a compelling point with a lower utility bill. I’m interested if I’m in the minority in leaving my equipment powered up? I haven’t had any major issues with leaving it powered up - most of the issues that I’ve had have always been related to a software upgrade of some sort. However, with this latest issue, it may be something to consider.

Dave -

Thanks for the link to the earlier thread - I will do some reading on that and see if there are things that could apply. I am using ZC due to too many devices, and while I hate to disable some of them, it may be necessary to troubleshoot this issue.

Connecting the trainer directly to Apple TV is a good idea, and one I’ll try this afternoon to see if it solves the problem. Just another step in the troubleshooting.

Thanks to all for the suggestions.

1 Like

That link is just to a post I made in a game update thread, it wasn’t really related to the resistance. I just think that there must be something amiss there, because there’s no reason at all why it should start trying to interact via Bluetooth on my setup. When I actually had the resistance go in reverse like you have, it was when I disconnected my HRM (from ANT+) and I’m almost certain I had the Companion app running. These days I just leave the app alone until I know my devices are paired and working, which seems fine. Again, not directly related to your setup and problem, just thought I’d mention it because it seems related IMO.

Here’s the thread where flipped resistance was discussed: Gradients reversed

This would be related to the Bluetooth connection I think. Try turn off everything, Apple TV also and start again. Also pair trainer direct to Apple TV, that might help.

As always, thanks to everyone for the suggestions. I will list the steps I took in my troubleshooting process:

  • I unplugged and “reset” my trainer
  • I then tried riding with my normal setup and the latest version of ZC; the result was reversed resistance
  • I reverted to version 3.36 of Zwift Companion; BINGO! Problem solved. I rode the Hilly Route in Watopia and everything worked exactly as expected. Resistance was correct and responded as normal.

Again, I didn’t think the issue was with my trainer or the base Bluetooth connection. The only thing that had changed recently was…Zwift Companion.

Don’t know why I’m the only person mentioning this - perhaps because most people are riding outside and may not be aware of the issue. And, of course, by the time they start riding inside, there will be several updated versions of ZC.

Again, thanks to everyone for their suggestions. I am grateful for the community which is willing to help.

Same issue. First test common setup: Windows 11, ZC bridge. With Saris H3 resistance was the same uphill and downhill, but very high. Changed my setup to Wahoo Kickr v5 and Climb - Climb height was change once only on start, then any slope changes during game. For second test I connected Wahoo Kickr v5 directly to Windows 11 laptop and everything works fine with slope changes. It looks like slope stops changing after during the ride after it is setup once on start, when using ZC bridge.

Tadeusz -

Not sure if reverting back to an earlier version of ZC is an option for you, but I will report that I have had zero issues since moving back to version 3.36. Sounds like that might solve the problem both with the Wahoo and Saris units. Hope you are able to get it resolved.

I have almost all options, now I use Win11 BLE (need to move laptop closer to bike) or Ipad with BLE, but Win11 ANT+ (with long USB cable) works fine. THX.

I’ve had this problem now twice this week. My setup is Apple TV and Tacx Neo 2T paired with bluetooth. The fact that a few of us reporting this bug are on different hardware and software suggests it is a Zwift bug.

The fix is easy enough — when I notice it I stop my activity, force quit Zwift and restart the Apple TV. However I would hate to have this happen when starting a race, and luckily the two times it happened I was just warming up for one and had the time to remedy before the start.

[EDIT: I should have mentioned that in my case I’m not pairing via Companion, although I typically run companion to use for chat and power ups since that is harder to do from ATV interface.]

I’ve stopped using the Zwift Companion as a bridge for my equipment, and I haven’t had the resistance issues since. It’s frustrating, because it’s rendered my Sterzo steering unit useless, but I’d much rather sacrifice that component and have everything else working correctly.

I think what is most frustrating is that when I first reported the issue, Zwift automatically assumes that it’s an issue with my trainer, and doesn’t think through the fact that the only constant in all of this is my trainer.

I’m curious as to what part AppleTV plays in all of this, as well. I don’t know if there is some sort of Bluetooth connection issue.

Sorry to hear that you’re having the issues. Hopefully Zwift will start to address some of these issues that are reported by a smaller number of uses. It feels like there needs to be loads of people complaining to get anyone’s attention.