Recovery from Apple TV crash

Nearly halfway through my group ride tonight (Herd’s Wednesday Wandering), my Apple TV apparently crashed. Completely black screen and the power light on the front of the ATV went out. Started it back up and launched the Zwift app to rejoin the ride. Got to the pairing screen and after everything paired right away, but before I could actually go to the next stop, the pairing screen cleared away and it had a small prompt that it found an interrupted ride, would I like to resume that. Before I could do anything there, ANOTHER prompt popped up asking if I wanted to join the group ride, similar to what I get after starting a ride in order to go to the pens. I accepted that, and it jumped me directly next to the ride leader for the ride. But I still had the first prompt about the aborted ride on the screen. In trying to get rid of that, I suddenly got teleported to London, out of the group ride (which was in Watopia on Tempus Fugit). When the second prompt popped over top of the first, it took the focus and there was no apparent way to get control over the first popup. I’m guessing that something I did made it think I didn’t want to resume the interrupted ride, so it started a new ride on the default world (I never got the screen with world/route selection during this process, but I know London was the default for me before).

I had to drop out of Zwift, restart it, start a new ride, and was able to late join my group ride with less than 2 minutes left before late join would’ve been cut off.

I wish this happened to me on my Apple TV. I totally lost my entire ride today, which included a speed record, 3 unlocked achievements and one of my best sprints yet… so infuriating.

As a followup…

Thankfully, I had no issues on my ride Thursday night, as I was the red beacon for our group ride.

The same could not be said about tonight, tho. I found an update available (version 1.0.49822), but it failed on several attempts to download it. When starting my ride, the May mission was missing and there was only 2 worlds available (Watopia & New York). Started the ride fine, but a little over 5km in, the Apple TV crashed again. Similar recovery to last time, but both prompts showed up right away. Dismissed the join group ride and resumed my previous ride (which left me riding alone in London), then late-joined the group ride. Another 5km or so later, Zwift crashed (back to ATV main screen). Launched Zwift again and had the same recovery experience. Thankfully, no more crashes the rest of the ride. After the group ride ended, a bunch of us stuck around for an ‘after party’ and someone decided they wanted to try for a group shot on the down escalator. As I neared the entrance to the Tube, I brought up the menu so I could use the pairing menu to brake on the slope. It worked. However, when I was backing out of the pairing menu, instead of going to the main menu, I got the world selection menu, like when first starting a ride. Then, suddenly, I was being teleported to NY.

After I quit the app, I tried the update again and it finally worked. Popped back in to check and the mission was displayed and there were 3 worlds available again.


Wow, that’s … disheartening. It makes me nervous to use my Apple TV and my Watch, even though these are supposed to be a key part of the Zwift experience. I can understand glitches with graphics, but basic functions like the actual ride itself :thinking:

At this point, I am forced to buy a Wahoo Tickr to track my HR because the glitches with the Apple Watch are so consistent it really affects my rides.

It’s quite clear that Zwift is just not taking the time to properly develop a product that supports Apple hardware. Ironically, the developer libraries and SDKs for Apple are leading the pack. It’s time for a reevaluation, Zwift.

1 Like

I’ve had similar problems, twice now, since the recent update. I’ve used ATV without issue for about 6 months, with a Kickr, and 4iiii HR strap. Seems too coincidental that it has happened twice, yesterday and today, but never before? Both times I was finishing a race (of course- in the last 1km), and my screen just went black. Hitting the Menu button re-woke the screen- but logging into Zwift again didn’t put me back in the race. It recognized an aborted workout in progress, and when I click continue, it puts me on the course, but not in the race. I wasn’t “closing” the App in the past after finishing a session, have read that can help? Perhaps the graphics update draws more power from the device, and it’s overheating? Or, it’s just an unstable update needing a bit more review.

Exactly the same happened for me yesterday near the end of a race. First time this has happened after a couple of years of using ATV with Zwift. Hope this gets fixed

1 Like

Curious- does your ATV console live a fair distance from your router? Mine’s in the basement, a floor down from my WiFi source. My thought is that the update might be requiring higher Mbps, and the ATV isn’t getting enough data transfer. More people on the system, it’s requiring much more from the console to keep up. I also think that’s why it’s only why it has happened in races or larger group rides for people. Other thought was overheating, or just plain processing power issues due to graphics demands. I’m going to add a WiFi extender close to the system that has a direct Ethernet connection to ATV, will see if that works… Makes me reluctant to do any more racing until it’s resolved, quite frustrating to be in the last bit of a race only to “crash”.

Hopefully Zwift will speak to issues with the update soon!

Not a wifi issue for me. My ATV it connected to the router via ethernet! Here’s the screenshot that Zwift automatically took, coincidentally at the time of the crash
Zwift ATV crash|690x388

lol that’s spooky! Did your screen go blank after that?

After more crashes on Saturday, I reinstalled the Zwift app on my ATV. Since then, I’ve done 3 group rides with no issue. I’m hoping that the crashes were due to something going wrong with the update.

If that was the cause of the issue, I still think that doesn’t excuse the recovery process with the two conflicting popups, one covering the other, or the fact that I got teleported to a different world without prompting.

To answer your questions, my ATV4K is probably 3 or 4 feet away from my WiFi router, separated by a very thin wall. The rides where it was crashing weren’t particularly large (400-600 people, usually) and I’ve been in much larger rides (like Greipel’s ALS ride and Bo Bikes Zwift) without issue. I usually assist with sweeping on social rides, so I was off the back with just a few people around me on all 3 rides when it crashed. 5 crashes in 3 of 4 rides.


I just had Zwift crash on me for the second time this week. Latest update an issue?

I had my first Zwift (ATV) crash earlier in the week, reinstalled the app, only to be followed by another crash today :frowning:

1 Like