Recommendation for Computrainer Cable

Can someone point me to a confirmed working cable (FTDI USB to Stereo adapter) that they have used for using a computrainer with zwift?

Any three ring stereo cable will work.

Ray

Hmmm…I don’t think so. It needs to have a USB end to it. It must be a FTDI USB to Stereo adapter cable - at least according to everything I’ve read. The PC won’t interpret the serial signal over the audio jack it needs to be input via a USB port.

Are you talking about the FTDI adapter or the cable?

Maybe this - https://www.amazon.com/gp/product/B01FPYACQ2/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1

Yes. I’ve found several out there and my post was actually asking for someone with 1st hand experience with one of the FDI adapters.

Yes to the cable or the adapter?

I have a few USB to serial adapters around…

I’ve got a ton as well. None of the FTDI’s though.

I’m looking for someone that is running their computrainer with Zwift and using a FTDI USB to Stereo adapter and can let me know the specic model/mfg they are using.

Since I ran mine for the last 5 years I think it’s ok. Nothing on the adapter, it does show FTDI, 0953-8, 8684801, FT232RQ on the chip inside the adapter.

http://www.racermate.net/forum/viewtopic.php?f=4&t=6203&p=24577&hilit=zwift#p24577

http://www.racermate.net/forum/viewtopic.php?f=4&t=6203&p=24575&hilit=zwift#p24575

https://www.amazon.com/gp/product/B07PNZ915F/ref=ox_sc_saved_title_109?smid=AJANC5JW6FQGH&psc=1

1 Like

I have two FTDI cables and tried to get this working with Zwift - I can’t get reliable pairing. Tried two windows laptops with the driver installed. Tried uninstalling and re-installing Zwift. It just doesn’t find the computrainer. I have two computrainers and both are doing the same thing.

Do you have a comm port in device manager?

I’ve got a lot of comm ports in device mgr. Do you know what specifically it should be listed under? The connector does flash when connected and the computrainer is on but zwift just doesn’t recognize it.

Do you know your latest firmware on the head unit?
I think it needs to be 45.XX to work with zwift.

I assume it’s the number when the unit is turned on. 25.41. Looks like you need to actually swap out the chip in order to upgrade the firmware. I’ll start looking around.

Open the device manager up so you can see the ports and remove the USB adapter. One port should go away. Zwift should find that port to see the CompuTrainer.

Yes - it shows up as “USB Serial Converter”

Zwift should find it then. Do you still have the Racermate software installed? You could check it with that.

That software is long, long gone. Don’t even know if I have a machine that will run it. But I’m wondering if the previous comment about the firmware revision of the handlebar controller is an issue.

http://www.racermate.net/forum/viewtopic.php?f=4&t=6276&p=24675&hilit=Zwift#p24675.

I do not have updated EEPROMS…

So - does the ct FTDI connector need a newer version of the handlebar controller in order to work? Are you running a ct with zwift? If so, what version are you running?