Recent Update Broke BLE on MacOS

When you’re on the pairing screen and start pedaling, do the power and cadence register? You should see them go from 0 watts and 0 rpm to whatever. That would confirm that the trainer is actually paired, seen, and registering w/Zwift.

Perhaps, unpair everything. The pair the power, cadence, and controllable again :man_shrugging: Maybe this will flip whatever bit is stuck and get your resistance corrected??

that’s the strange thing – everything registers show power shows rpm all that stuff but the resistance stays the same ? I don’t get it

Once in game, open the settings up. What is the trainer difficulty set to? By default, it should be in the middle (i.e., 50%). But, if it somehow is set all the way to the left, that would explain things.

Hmm…

Do you have a head unit (e.g., Garmin, Wahoo, etc…) turned on as well? If so, perhaps turn it off. Also, disable Bluetooth on your iPad and iPhone for the time being. Then unpair and re-pair everything in Zwift on the MacBook.

I’m quickly running out of suggestions :sweat_smile:

Nope no headset or anything – the only thing I have on is my laptop – turned phone off / turned iPad off – nothing is working – I don’t get it – I give up – every since this update – it’s F’ed everything nothing works – it shouldn’t be this hard.

Is there an Elite app or some other app you use on your MacBook? Perhaps try that to verify that the trainer is working as it should. You could download Road Grand Tours or Rouvy to test things. I believe both have free trials or are in beta ??

If it works correctly in another app such as RGT or Rouvy, then I believe you could say 100% it is a Zwift issue and not a trainer or MacBook issue.

I can try that – but why would it stop working the same time the update happened - that doesn’t make sense - the update happened and now things stopped working it would be a major coincidence that the update happened AND my trainer all the sudden doesn’t work.

There is a high probability that Zwift has hosed something. The recent slew of updates is Zwift trying to correct an issue albeit unsuccessfully. It would seem that they made a change and broke something for many users. The fix apparently didn’t fix it and/or broke it for a different set of users. Rinse and repeat. FAIL and more FAIL.

Oddly enough, it works fine for many/most users :man_shrugging: I’ll personally find out in about 45min if Zwift is still working for me. I’m also all Apple (MacBook, iPhone, AppleTV). But, I use a Neo. So far, my AppleTV 4K and Neo have been unaffected (knock on wood).

Good luck my friend !!

Good news and bad news. Good news is that it worked fine allowing me to complete TdZ Stage 5. Bad news is that it worked fine which doesn’t help you.

I did have a thought (well several actually :grinning_face_with_smiling_eyes:) while I was riding. One in particular was that perhaps you could try only power and controllable, no cadence. Also, if it doesn’t work, then change the pairing order.
test case 1: <1> controllable <2> power
test case 2: <1> power <2> controllable

I would try a calibration on your trainer via the Elite app. It might reset something that Zwift has messed up, and you can see if that bit at least works normally.

I’ll try the above recommendations see if I can get something to work. Thanks

Nothing worked – Steve I recalibrated my trainer with the Elite app and still nothing.

Does Zwift every chime in on this – I’m a little more than pissed right now. How and update of theirs can keep me in the dark for 5 days now. What the ■■■■ can’t they figure out what was wrong?

Maybe you mentioned it above, but did you open a support ticket with Zwift or Elite? While Zwift does have employees periodically looking at the forum here, this is not the place to contact Zwift for a support issue.

iPhone and iPad OS were both updated today. Perhaps try updating those devices, then trying the latest version of Zwift on those once again.

Did you try power and controllable only?

edit: Since you are using Bluetooth, does the Direto via it’s app allow you to disable ANT+? If so, I would disable it. One less possible source of problems.