Recent Update Broke BLE on MacOS

The release that happened last Friday has me still unable to use Zwift.

I’ve tried it via the app on my phone - I have have the iPhone Xs Max (doesn’t work)
I’ve tried it via my iPad (doesn’t work)
I’ve tried it via my Mac - I’m running a Mac macOS Catalina (doesn’t work)

My smart trainer is an Elite Direto XR

I’ve tried all the trouble shooting you’ve posted in your forums but again NOTHING WORKS

There was an update to Zwift on iOS and ATV today that is supposed to resolve this issue.

Update does not work - still will not connect.

Do you have today’s update installed on your Mac (see above).

Screen Shot 2021-01-25 at 2.57.43 PM

Can you connect to the trainer via the Elite apps?

1 Like

The only app I’ve used since I’ve gotten my trainer is Zwift - but yes I connect fine to the myETraining Elite app and my Elite Upgrado app - those both work fine.

Assuming that you’re connecting via Bluetooth - each signal can only pair to one receiver at a time. Please make sure you’re unpaired from any other app on your smartphone, or other apps (Garmin Connect, etc) that may be running on your Mac.

We’re watching very closely for residual issues - would you loop back and let us know what happened?

1 Like

All on this thread:

We’ve been working over the weekend to fix a bug that could cause some users to be unable to pair via Bluetooth.

Version 1.0.61590 for Mac and PC is live now. This patch is numbered 1.0.61590 for all OS’s.
Android will follow shortly, then iOS and AppleTV.
Once the update is released on Apple’s App store, you can go directly to this page and you should see the “Update” button to force a manual update.

UPDATE: v1.0.61590 is live for all OS’es.

1 Like

I’ll try that and get back to you.

Still unable to connect -

Seriously dead in the water since Friday you’re release has F’ed up everything I can’t connect with laptop / iPhone / iPad - seriously not happy with the experience so far.

You shouldn’t be connecting or pairing your trainer via the Mac Bluetooth settings. It only needs to be paired via Zwift.

This applies to the iPhone and iPad as well. If you have paired your trainer to any of them via Settings > Bluetooth , go remove it immediately (i.e., Forget This Device)


Ok tried that but it doesn’t work either - Zwift says it’s paired and I start a ride and nothing registers like it used to - I can be in my easiest gear and it’s as if I’m going up a 12% incline - it’s still not working.

And even after you forget the device when Bluetooth on the Mac will till try to discover my trainer.

Just extremely frustrated – everything was fine NO ISSUES at all and now 4 days later nothing works.

As long as you do not pair it to your Mac, iPhone, or iPad directly, you’re good. They can all discover whatever they want but will not connect. But once paired, they will typically try to automatically reconnect. Hence, my instructions to go “Forget This Device” on all your Apple devices in the Bluetooth settings. Aside from making sure Bluetooth is actually turned on, there is no reason to ever open your Bluetooth settings. All Zwift Bluetooth pairing is done directly from within Zwift.

For your MacBook there is a hidden Bluetooth menu. <Shift + Option> while clicking on the Bluetooth icon in the system tray. Now select “Remove all devices”. Then do it again and select “Reset Bluetooth module”

Once this is done, launch Zwift. In the pairing screen, make sure that the trainer is at a minimum paired as controllable if not also power and cadence. I don’t know if you have another power meter and/or external cadence sensor. But, “controllable” is a must if you want gradient resistance simulation.

Lin - first thank you for taking the time to walk me through all this - I did all the steps you outlined above and Zwift keeps appearing likes it’s all connected and working but it’s not. It doesn’t matter what gear I’m in the resistance is the same.

What is selected if you click on the settings gear icon in the upper right of the screen? Is it set to use built-in Bluetooth?

1 Like

That’s bizarre. As a last resort, how about rebooting your laptop. While it is rebooting, power cycle the Direto as well. :man_shrugging:

Are you on the latest version of Catalina, that is 10.15.7 ? If not, recommend you update. No need to go to Big Sur.

If it still won’t work properly after a reboot, then perhaps try the iPhone and/or iPad after exiting Zwift on the MacBook.

Tried all those and yes on the latest version of Catalina (10.15.7) - that’s what makes all this so frustrating - I’ve been though all these exercises - poured though the support stuff yesterday and it doesn’t seem to fix it. I’m at my wits end.