Raining in the Underground [SOLVED]

@shooj: a few odd items on today’s ride, after having updated:

The first two (riders in the grass) might be due to them not having updated their systems today, but the last one (raining in the Tube station) is definitely one I have never seen before.


Pretty sure it’s unrelated to update. I was riding in london yesterday and hadn’t updated yet and it was raining under the bridge. It was like the map and weather were out of sync by 3-5 seconds. I took a picture it made so little sense .

Thanks @Nigel_Tufnel I’ve forwarded your report to our bug zappers.


Update: this has been solved in game version 1.0.53592


1 Like

Is that an imminent release or an interim version number?

Good question. My PC is presently at 1.0.53342, so it seems like the ‘solution’ will be in an upcoming version.

1 Like

For the record I was riding a couple of days ago and it rained in the Underground tunnel - I was amused :slight_smile:

Hi @JaffleOz
That’'s because 53592 is our next release.


I ran Zwift in my old core duo 2007 iMac the other day OS10.11 ( the latest available)
After it had upgraded ( slowly) to the latest version of Zwift

I did a lap of London ( where recently it always seems to be raining) and it was still raining I the waster tube tunnel near tower bridge.

Generally this computer runs applications as fast as my iPhone and iPad. Why does Zwift take so long to load on my iMac, where its almost instant on the tablet and phone?

I know the graphic card is low resolution and low frame rate, but why the slowness before the game even starts?