Problems detecting stickers with the runn

I’ve bought the Runn for my threadmill and placed it as described. Than I tried to calibrate but there’s no chance detecting the stickers. I’ve got three stickers on the band, I’ve changed them, I tried with double lentgh stickers but nothing works. I also changed the distance Runn to band.

Thats the way I tried:

  1. double click to activate Runn
  2. single click
  3. single click and hold for about 6 seconds
    Than the lights flash front-middle-last front-middle-last front-middle-last and than, while the band is running, the front light is permanent on. The stickers cross the sensors, no flash, nothing.
    I also tried to hold the switch for about 10 seconds and than again 1. to 3. but also nothing.

It’s frustrating :frowning:

Anybody who can help?



For me the initial calibration only worked when I powered the device from the mains (it did not work when using the internal battery). Maybe you are seeing the same issue.

You may have to adjust the position of the sensor, I had to move mine out an inch and it works much better. I also noticed the stickers have to be clean.

I also super glued the stickers to the belt as the adhesive they gave was useless.

Have you done a firmware update. The firmware that comes supplied is a little buggy. Also do a factory reset and this tends to help.

Sticker placement can be a fine art but as previous poster says you’re much better off super gluing them on.

The RUNN is the most useless frustrating device sold.

The support for the device in ZWIFT is pretty bad as well - the readings are erratic never mind how many times you do the calibration. Zwift does not factor in the incline. Complete wast of $100.

Now I think so too. I keep getting the same message from service that I should follow the steps in the instructions. I’ve done that x times. Totally annoying and frustrating.

Have you tried contacting NPE as their support is great. Normally get a reply within an hour.

The latest I got from them is that they do not recommend calibrating the device in Zwift and to use the configuration tool Configurez.

There also seems to be an issue where the device won’t configure. If this is the case do a factory reset and it’ll jump into life. NPE are looking into this.

today I’ve got the solution by NPE-Service (which was fast by the way):

I’ve connected my smartphone with Runn using the NPE Configurez-App. At first I did the update for the Runn-firmware. After that I’ve selected “Restart Runn”. Than I could calibrate incline (which now works) and after that… speed! Yeah! It works.

Tommorrow or maybe on sunday I’ll connect to Zwift and try out. That shouldn’t be a problem because it worked before.

Thanx again!

Glad you are sorted. As I said NPE are looking into the issue whereby you have to do a restart to kick the Runn into life

So, it works well with zwift. I’ve had three units. Don’t know if I have to calibrate again at the moment.

Thanks a million and please keep up the effective work.