Power data incorrect

Hello! Since the last update, i have problem with the connection to the trainer and the power data zwift displays. Here’s what happens:

  • open Zwift and on the pairing screen confirm all ANT devices (speed, cadence, resistance)
  • start a ride with a pace partner or a group event
  • the power reading responds somewhat to reality, but within a few seconds it drops and freezes at a certain value

When i try to forget and re-pair all the sensors, the result is the same.
When i try to use Bluetooth, at first the pairing screen finds the device but then it says there is no connection. When i try to re-pair, the search takes very long and only finds the device if i search for the speed sensor first. Even after selecting Blluetooth sensors and joining a pace partner, the problem persists - the power reading drops and freezes.

I tried rebooting the trainer, restarting Zwift, turning bluetooth on and off, removing and reinserting the ANT dongle, turning Companion app off, joining a pace partner in a different world. A few times this helped (eg i could ride with the same pace partner in makuri, but not in watopia), but not always.

Here are the details of my setup:

  • Zwift version: 1.29.1 (105318)
  • Operating system: Microsoft Windows 10 Enterprise 10.0.19042 N/A Build 19042
  • Trainer: Wahoo Kickr V5, firmware version 4.2.8


Today i tried using the same trainer but with a different computer with macOS and it worked without a problem.

2022-10-11 - today the trainer wouldn’t connect at all. i installed Wahoo RGT and it worked without any issues
2022-10-10 - since yesterday i started having the same problems also using macOS… every day i have to spend around 15 minutes before each ride to start zwift, reconnect, restart, etc to get it work…
2022-10-04 - i tried to reinstall zwift completely, but it did not help. there is no resistance and sometimes when the ride begins my avatar ends up off the road: