Power/Cadence Sesnsor Dropout without MacOs Reboot

Recently I have found that my Power and/or cadence sensors are dropped after a couple of minutes riding unless I reboot the Mac before starting Zwift. My current setup is as follows:

  • Macbook Pro (2017) with OS Catalina & Ant+ Dongle
  • Quarq Power Meter (also provides cadence)
  • Wahoo Snap tranier

When I first login to Zwift it sees all sensors - (Power, cadence, trainer, heart rate).
I then start riding (or join a group ride) - the ride starts ok but after a couple of minutes the Cadence & Power ceases. If I reboot the Mac and restart Zwift everything connects again and everything works fine.

It is more frustrating when I am planning to do a group ride - the sensors all remain connected during the “warm up” prior to the ride starting but then drop out after a couple of km. Restariting the Mac & Zwift & rejoining the ride fixes the issue.

I have tried just re-connecting the sensors and re-starting Zwift without a reboot but once the sensors have dropped they will not reconnect.

Has anyone else seen this and are there any known work arounds apart from rebooting the Mac everytime I run Zwift?

Could the issue be that either the Bluetooth or ANT+ stack on the Mac are being left in a bad state after Zwift exits (either by Zwift or a bug in Mac OS).

Further things I could try:

  1. Connect using Bluetooth instead of Ant+ (or Vice Versa) next time it happens
  2. Run Xwift complete a session and exit. Then re-start Zwift and see if teh problem is encountered.

Any ideas suggestions greatly appreciated.

This is a hard one.

Do you have a extension cable for your ant+ dongle.

You can use zwiftalizer.com to look at your log file to see your ANT+ dropouts.

I will take a look at zwiftalizer.com next time it happens (either tomorrow or Saturday)…

I am currently only using very short cable (usb-c to usb) but I don’t think that will be a problem as I have been using Zwift for 14-15 months and this problem only started happening recently.

I first saw this issue back in July after updates to MacOs, Zwift and the Quarq Power Meter firmware; back then I spent quite a bit of time faffing and the problem went away once I rebooted the Mac. At the time I assumed that one of teh updates are left something software related in an undefined state…

It did not happen again until 3 weeks ago and since then it has happened every time I ride on Zwift. As soon as Mac has been rebooted everything is reliable until next time. I am usually keen to get riding so I have been opting for a reboot without spending any time trying to diagnose the problem.I will have a more detailed look and report back anything I find out.

  • New source of interference?
  • USB dongle going bad?
  • USB extension going bad?
  • Try a different USB port on your Mac?

Following teh advice on this thread I have replaced teh battery in my Powermeter which appears to have resolved teh issue. The battery was strnmg enough for teh signal to be read by my Garmin but must have been causing dropouts with the MAC.

I have managed 2 rides so far without needing to reboot the MAC since replacing the battery. hopefully the issue is resolved.

Thanks for eth suggestions.