Does anyone know why my pictures I take while riding on Zwift are not saving to my photos?
Ive tried taking them on my iPad while in Zwift and I’ve tried taking them from my iPhone in companion and neither are working.

Because Zwift doesn’t save them to the photos gallery.

The photos are saved to the app folder on the iPad which is impossible to access without connecting the iPad to a computer and using third party software to browse the app folders. Just yesterday I deleted nearly 1000 screenshots had accumulated in the app folder over the last 7 months of Zwifting.

I think Zwift expects you to upload the photos as part of your activity at the end of the ride and then you can use the Companion app afterwards to email them somewhere else.

I’ve found the only way to get easily accessible screenshots from Zwift is to use Apple’s own inbuilt screenshot feature.

Do one of the following:

On an iPad with a Home button: Simultaneously press and then release the top button and the Home button.

On other iPad models: Simultaneously press and then release the top button (on the top-right edge of iPad) and either volume button.

Tap the screenshot in the lower-left corner, then tap Done.

Choose Save to Photos, Save to Files, or Delete Screenshot.

If you choose Save to Photos, you can view it in the Screenshots album in the Photos app, or in the All Photos album if you’re using iCloud Photos.

1 Like

Are you saying that EVERY photo that has been taken while Zwifting on my iPad is being stored somewhere on my iPad that I can’t directly access from the iPad? That seems ludicrous. If this is true, I really would love to access these photos and delete them, as I am sure they are taking up a fair amount of space at this point.

Is the same thing happening on Apple TV?

1 Like

This must be something which can be enabled, though, because every screenshot I take using the Companion App (on my iPhone) is saved to my Camera Roll (again, on my iPhone).


Have you checked the Companion app settings in your phone to be sure the Photos access is set to ‘None’?

1 Like

No, Apple TV doesn’t store photos locally. When used with an Android phone for ZC (I don’t have an iPhone) the photos are stored locally on my phone. I’d be surprised if the same thing doesn’t happen with an iPhone connected via ZC.

1 Like

It always used to save to my phone photos album until the update before last and that’s when it stopped working

Maybe it can, maybe it can’t.

I just checked and in Apple - Settings - Zwift the access permissions to Photos is set to “Add Photos Only” (the other option is “None”) so I don’t know why it doesn’t work for me.