Pairing Options Changed


(Chris Bishop) #1

A few weeks ago I noticed my pairing options changed. I typically connect my POWER to KICKR XXXX and my CONTROLLABLE to Wahoo FE-C XXXX.  This was the only setup I could find that limited power drops.   Now, the KICKR XXXX option is gone and I am forced to use Wahoo FE-C XXX for both POWER and CONTROLLABLE.   I have been working with both Zwift and Wahoo but neither has been able to find the cause.  

Anyone else have this issue and solved it?  I am getting too many quick changes in power and it really taking away from the ride experience. 


(Paul Graham) #2

Hi Chris

Have you tried renaming the prefs.xml file, forcing Zwift to go on a ‘fresh’ search?

You also have a 'knowndevces.xml that should have the code-number of your devices, as they are now and what has been used in the past.

Example from my Kickr set up:

<DEVICE>[0] [768348] [2097153] KICKR 47452</DEVICE>

If you have the original Kickr number in there you could try copying that number into the prefs.xml .

Example from my Kickr set up.

<LASTPOWERDEVICE>768348</LASTPOWERDEVICE>


(Chris Bishop) #3

Paul -

Thanks for the ideas.  Unfortunately neither of them worked.   I did go to a friends this evening to see if his Kickr was behaving the same.  It was not.  I then tried to connect my computer to his Kickr and I was NOT able to connect to KICKR XXXX.  

Thinking this may be related to my computer or my credentials?  I did reload Ant+ drivers.  No joy there.

Any other good ideas out there?


(Cary Sporinsky TeamZF ZHR(F)) #4

Wahoo FE-C works fine.

 Have you even tried a spin down?

Have you tried updating KickR firmware?


(Chris Bishop) #5

Cary, I wish FE-C did work fine. Unfortunately, as soon as I lost the option to connect to regular ANT+ for my power, the power drops returned.  

I have tried updated firmware and a spin down.  I have also gone through all the troubleshooting tips on bad connections.   Sigh…very frustrating.

Thanks for the suggestions, though!

 


(Paul Graham) #6

Hi Chris

As an aside, was there a Kickr xxx entry in your ‘knowndevices.xml’?


(Chris Bishop) #7

HI Paul -

Yes…there was a Kickr XXXX entry in ‘knowndevices.xml’