Old story.. Zwift and Kickr Core resistance solved (for me)

I, and many others, have complained in the past about the resistance when using a Kickr Core at 0% gradient on Zwift. It happened using an Apple TV, and was just the same on PC. I was always using the Wahoo Fitness app in workout mode to add resistance while riding on Zwift in order to have a realistic feel and range of gears. The resistance sent by Zwift at 0% (using Bluetooth) is unrealistic and much too low.
Sick of slow and unreliable connection using Bluetooth on my PC, this week, I tried an ANT+ USB stick (Garmin) , and apart from the very fast connection at startup, the resistance at 0% is fairly close to normal!
Why is there a difference in resistance between Bluetooth and ANT+ ?
Is Wahoo or Zwift at fault with this problem?
I suspect the fault is in the Zwift program …

You may find the answer in an article on Zwiftinsider (can’t link to it in a reply). Search for WAHOO KICKR TESTS: CONNECTING VIA LEGACY ANT+, ANT+ FE-C, AND BLUETOOTH:

" We headed out to Fuego Flats, turned our Trainer Difficulty down to 0, and rode for a minute or more at a steady cadence of 90 without shifting. We did this for each of the three connection methods. Here’s what we found:

** ANT+ (non FE-C): 184 watts average*
** ANT+ FE-C: 215 watts average*
** Bluetooth: 182 watts average"*

ANT+ FE-C uses a higher base resistance than Bluetooth or normal ANT+.

1 Like

Bear in mind that that Zwift Insider article is 18 months old.

Wahoo recently added (via firmware updates) Bluetooth FTMS support to the Kickr, which had been missing before. On 1 June 2021 they added that to the Kickr Core too. See KICKR CORE Firmware Updates – Wahoo Fitness Support

So it’s worth checking your firmware is up to date.

@ Steve
My firmware is always updated!
Past firmware changes to date have never resolved this problem using Bluetooth (on any platform) on Zwift.

I have , as always, updated my Kickr Core firmware.
I updated my Zwift app to the latest (15/6/21)
My resistance at 0% gradient is now close to normal when using Bluetooth…
Why did it take so long to get it right , Zwift…?

Hi , I think I am having this problem. How did you solve it?

It seems the problem has been resolved since July. Make sure your trainer firmware and Zwift are both up to date.

Yes I have done that unfortunately it’s still not working. Any other tips?

So, I’m using a Wahoo Kickr Core. I updated the Kickr firmware, and then had to wait for the Zwift update.
If you have installed both Kickr and Zwift updates, it should be fixed.
Another option, if you are using a Windows or Apple computer is to use an Ant+ dongle and use the Ant connection for your ‘Controllable’ Smart Trainer connection, rather than Bluetooth.

Is the latest firmware 1.1.1 for wahoo Kickr core?

Zwift is updated too.

Does this require a lead to laptop or is it wireless

1.1.1 is the latest Kickr Core update. I find that the Ant+ connection has a better 0% resistance. I use a Garmin USB Ant Stick. It can be plugged directly into a USB port, or as I have done, it can be connected to a shielded USB extension cable to reduce interference from the computer and increase the signal from the Kickr Core.