Kickr Core issue: very little resistance / trainer difficulty disabled


  • Wahoo Kickr Core
  • Wahoo Tickr Heartrate monitor
  • Wahoo Cadence Sensor
  • Zwift running on OnePlus 8T smartphone (Bluetooth)

At first it worked great.
Yesterday the issue started. I experience very little resistance when riding in Zwift. I’m pushing 120RPM on my 53/11 gear and the output is 120 watts.
When I look at ‘trainer difficulty’ in the settings, the slider has disappeared.


What I’ve tried:

  • Reinstalling Zwift: this temporarily resolved the issue yesterday, but when I wanted to race on Zwift today the same issue had returned.
  • Disconnecting/forgetting all sensors in other apps I use (Trainerroad, Wahoo app) … nothing
  • Forced closing Zwift /power off on Kickr Core / disabling bluetooth / … nothing

Any help would be much appreciated!

Android bug? Are you pairing via Bluetooth or ANT+? Disable one and try the other.

Then there is always:

Oneplus 8T runs on Android 11 indeed.

It does not have built-in ANT+ so I can only connect via Bluetooth.

I am going to do some more troubleshooting on my own, and if I don’t find a solution I will contact Zwift support.

Is the spin down calibration of the trainer successful? I had a similar problem and when I tried to calibrate it always showed as unsuccessful using either Zwift or the Wahoo android app.

I have tried both, spindown in Zwift and in the Wahoo App. They are successful but it doesn’t solve the issue

Ok, I had a very similar problem with my core a few weeks back in that there was very little resistance (although I could not get a successful spin down). I did about 4 spin downs in a row using the wahoo app (not zwift) and eventually it worked. Ever since it has been fine. There is an option to complete an advanced spin down using the wahoo app, might be worth a try.

When you are in the pairing screen and click “Controllable”, do you have more than one device choice? The lack of Trainer Difficulty suggests you dont have a smart trainer (which of course you do). I have a normal Kickr and ANT+ and I get 2 choices, Kickr with FE-C and one without, hence wondering if you have similar.

Bluetooth doesn’t have that FE-C option, so it’s simpler in that way.

1 Like

Yeah makes sense in hindsight given FE-C is ANT+ protocol. Stronger wakeup coffee next time!

Same issue with my 1 week old Kickr Core and Macbook Pro (also tested on my iPhone 12)
Any news from your side?

I got it working again, hopefully for good now.

What I did:

  • Uninstall Zwift
  • Perform a system reset of bluetooth on my smartphone
  • Disable bluetooth
  • Reinstall Zwift
  • Enable bluetooth
  • Run Zwift. Once running, never go out of range with any of your bluetooth sensors (including heartrate sensor)
  • Ride/workout/race on Zwift
  • When I’m done, I close Zwift, then I ‘force close’ it (making 100% sure it’s not running anymore), and finally I disable bluetooth. Only then I go out of range with my bluetooth sensors.

I’ve read in other topics that Zwift used to (they say they’ve patched it) sometimes send out weird commands to Kickr Core once you go out of range with a connected bluetooth sensor (such as going to the bathroom with your heartrate sensor on). These weird commands could be the reason why the resistance is way off. This is pure speculation on my part though, I’ve got nothing to back this up with…

1 Like

Hello Philip have you found a new solution? sadly nothing worked for me for the last six weeks I am not able to go on a free ride despite having installed deleted almost everything on the computer a couple of times.

Unfortunately I haven’t found any new solution. The above worked for me twice, but I can’t say it’s a permanent fix for me since I haven’t done any rides on Zwift in the past 2 weeks. Good luck and let me know if you find anything

Danke Philip,

I’ll let you know.