Ocean Lava route took a wrong turn

I started the new Ocean Lava Cliffside Loop this afternoon.
I properly selected the route. Before I got to the volcano, I was forced to turn left into Watopia rather than straight ahead and onto the Volcano reverse. Not having memorized the route beforehand, I continued and did complete the loop, went under the arch, but got no badge. I rode another mile or 2 and quit at about 12 miles.
I then studied the route and had another go at it. This time I was properly routed around the volcano and continued properly and this time went through the arch and was awarded the badge.
I checked the in game badge page, and found that there are no badges posted yet for the 4 new rides. Having completed them all, I was disappointed not to see my badges. Perhaps someone at Zwift could look into both the badge situation, and why I was directed to take a wrong turn on my first go at the Cliffside loop.

Are you logged in on more devices?
Seems to be a common problem and source of different issues.

Zwift steered me wrong on my first ride of the Ocean Lava Cliffside Loop route, on day one of the new roads.

Routing worked correctly on the second ride, and I got the route badge.

[I use a Windows 10 PC and am not logged in on more devices.]

No, logged in as normal. Kickr, Scosche HRM, and ZC on Android phone. Win 10 with ANT+ dongle. Setup has worked for years.

New bug? I got the badge on the 1st or 2nd day after update, no issues (all four new routes).
Last idea - manual turn?

Ride on!

@Reed_Markley
Thank you for flagging this up. We’re opening a ticket to look into it.