NPE Runn Device no Bluetooth Connectivity

HI all

Have searched these forums, Zwift and NPE Support Pages and awaiting feedback from NPE themselves, but yet to bring my issue to conclusion.

I’ve been using the Runn device successfully for around 9 months now, but this week it stopped connecting to my devices, including Configurez and of course Zwift. The device previously showed up as a Bluetooth connection in my iPad (my Zwift device for running) but no longer does.

It seems to have stopped transmitting via Bluetooth but hoping someone may have had a similar issue and perhaps managed to resolved it.

I should add, it is not connected to any other device.

thanks

ian

Update:

Contacted by NPE pretty quickly in the end. Got walked through the fix via email, here’s their solution should anyone else get this issue:

Take a T7 screwdriver (precision) and remove the 6 screws from the back. Gently ease the battery connector out and then back in again. This should then reboot the bluetooth.

Worked perfectly for me.

Ian