No gears displayed [Wattbike] [1.34] [SOLVED]

Yep same here mate

yup. That is the issue. Gears work ok but do not appear in the top left hand box. I am using the original wattbike atom and a Mac M1.
Thanks and looking forward this being resolved.

Yes the gears work but not displayed top left under wattage where they used to be. I am using next generation Wattbike Atom.

At the risk of derailing this Wattbike thread - the Stages issue sounds the same, but we found it has different root causes when we investigated. The Stages data transmitted over Bluetooth communicates the commands to change resistance when you shift, but the packets that communicate which gear you’re in appears reserved for the Stages app.

Have any of you tried the SB20 with other apps, does the gear shift indicator work in them?

2 Likes

Thanks everyone for detailing the symptoms more clearly, and confirming our findings. We’re working on this and I’ll update this thread when progress has been made. We appreciate your patience!

6 Likes

FulGaz works with gearing display from the SB20

1 Like

Thank you for the info.

1 Like

Thanks for the update Shuji, much appreciated.

1 Like

Any news about the gears not showing on the watt bike atom ???

1 Like

I had an e-mail from the support team asking for screen shots which I have sent them. Hopefully they will resolve it soon.

1 Like

Same issue experienced since the last update, gears not showing on the windows app, opened the iOS app on my phone and the gears are showing. Email sent with screenshots. Was looking forward to a long ride today but a training session will have to do.

Thanks mine was working fine yesterday but the gear info from my Wattbike Atom disappeared after todays update. I even changed the battery in the right shifter thinking that was the problem but severed the wires and needed to solder them back! All very fiddly. Gear changes and display work fine on the Wattbike Hub just not on Zwift. Please fix as soon as.

1 Like

Same issue here since latest update. Gears working fine, just not displaying on Zwift.
Using Apple TV here.

I have the same issue too with my Watt Bike

Ditto. I’d like them back as soon as possible please

Just to add to the others in this thread

ATV = no gears
Win 10 BT = Gear showing

Yes, exactly the same here!!

Just to add another here, not seeing the Wattbike gear updating on screen on Windows 11 after latest update (1.34.0 / 109673)

Still not sorted…how difficult can this be to sort?! We should be able to revert to the previous software version…

1 Like

Please fix this asap - Thank you

1 Like