No cursor - Zwift cannot be used


(John Kelman) #1

When I launch Zwift (Windows 7), it switches immediately into full screen mode, and my mouse cursor disappears. The mouse buttons also do nothing, same for Tab, spacebar, etc. I can enter my password, and then get presented with the screen to search for devices, again with no mouse or keyboard control. The entire application is now totally useless - I cannot make a choice, press a button - nothing. Alt-Tab will switch to other applications (where everything including the mouse is working), and Alt-F4 will close Zwift, but that’s all.

I’ve uninstalled / reinstalled (twice), updated Windows, etc., etc. but nothing. Zwift was working a week ago, but no longer. Extremely disappointing and frustrating, particularly as I was trying to join the “Ride with Jens” event - what a joke that turned out to be.


(Jason K) #2

Moved to Tips and Troubleshooting.

I’m sorry you weren’t able to join the Jens event! I know that must have been frustrating, so I’m creating a ticket from this. We’ll work with you there to solve this for future rides.


(A Dooha) #3

I have same problem with WIN8.

Cursor disappeared in full screen mode and no way to get back. :frowning:


(Damian Oldham) #4

Same problem changed settings to full screen mode doesn’t work properly and cant change back. Have reinstalled app and still in full screen very frustrating


(Tony Milsom BMCC) #5

just taken the strava 2 months and now I have this problem too

 


(david wilson MDE) #6

I too have this problem. It laptop works fine when I use it (touch pad), but when I use my better performing (gaming video graphics, etc.) desktop hooked up to a 55" plasma, the cursor disappears. The TV is not the problem, because the HDMI connects and shows my laptop Zwift fine. It is indeed frustrating.


(david wilson MDE) #7

Found a solution (worked for me).

The following appears to have fixed the problem of the disappear mouse in full screen mode:

 

  1. Open: CONTROL PANEL
  2. Select: Mouse Pointers
  3. Disable ALL ancillary pointer behavior (e.g. shadows, trails, non-default pointer shapes, precision
    enhancement, Snap-To, Hide-pointer-while-typing… EVERYTHING! Just to be sure!)
  4. Run ZWIFT.

 

Not sure what the ancillaries have to do with ZWIFT but this worked for my machine (for now).

 

dw


(Sandro Verrelli) #8

David, thank you. I’m going to give this a try… will post the result. 


(Jason K) #9

The issue we found in this case - and with every other case I’m aware of - stems from running Zwift in fullscreen mode on multiple monitors. There are still some issues related to running Zwift with more than one display that we’re working to fix.

For now, if you have more than one display, I’d recommend running in windowed mode while we work to solve this. If you’ve already enabled fullscreen mode and can’t see your cursor, delete your prefs.xml file in your Documents\Zwift folder to reset your settings.

If you’re still having problems, submit a ticket with us via bit.ly/zwiftsupport, and we’ll help you further there!


(Tony Milsom BMCC) #10

@David Wilson   Thank you and your right - It was the cursor options for me at least - Disabling the ancillary cursor options fixed it.  

I was not using a secondary monitor - just the laptop

 


(david wilson MDE) #11

@Jason K, Just an FYI, I was not using multiple monitors either. And, Zwift only runs on my machine in full-screen mode (it literally loads that way). So, on initial installation it would be good to just recommend disabling the mouse ancillaries.


(> Happy Runner) #12

I had the same problem on a single monitor.

The mouse ancillaries had nothing to do with it.

In my case, it was caused by having the Window’s Magnifier program running, even in the background, and even set at 100% (i.e. no magnification).  Once I closed out Windows Magnifier, cursor returned.

 


(Fabian Dal Santo) #13

I had a case where I could start Zwift, but the mouse would disappear. The only way to get it back would be to delete the /Zwift directory and start again. I had to do this every time I started Zwift.  Turning off Mouse trails seems to have fixed the issue. I was using a single monitor.