No count down timer for event

As requested by Eric Min in Facebook group Zwift Duathlon, I’m reporting a bug regarding the issue of no count down timer for the event, where therefor you can not join the event.
Link to Eric’s comment: https://www.facebook.com/groups/ZwiftDuathlon/permalink/1049127188792869/?comment_id=1049176922121229&reply_comment_id=1049882178717370

I’ve managed to replicate this bug today, by signing up for a group bike ride at 1 PM CET, event id 339319, link to the event: https://zwift.com/events/view/339319

Upon entering Zwift, I didn’t get a count down timer for the event, exited, re-entered, the same issue.
I unsigned up for the event and resigned, still didn’t help.
Tried without pairing any equipment and with paired equipment, same issue.

The last time I’ve tried it, the event already started, so it was a late join, but the difference was, this time I have entered the scheduled world (New York today), instead of Watopia, where I always warm up on the Tempus Fugit course.

Screenshots of signed up event in the Zwift Companion app:

Screenshots from Zwift for the signed up event:

If the issue might be, that I was signed up for the bike and run events which started at the same time, I’m also attaching a screenshot for all the events I was signed up:
signed up events

The device used: PC, Windows 10.

I’ve uploaded all the log files from today, zipped, one drive link: https://1drv.ms/u/s!AnoBuO2krSk45B-g8FPOB15nU-da?e=OJ34yk

Perhaps I do not understand your problem exactly, but I have to click the RIDE button and the option for the event is on the next screen!

After I click RIDE button, there is no count down timer to join the event, the added screenshots were tho show that I was signed up for the event.
I didn’t take extra screenshots later on, as what I’m taking screenshots off? No JOIN NOW button? :slight_smile: Ordinary every day screenshot then :slight_smile:

Did you sign up for the event while you were in the Zwift menu (second picture), i found that that can cause an issue.

What I found if you are riding and don’t see the Join even button, you can go to the companion app and cancel the event and then re select the event and the join button will pop up.

also you should be riding in the Zwift world at least 5 min before the event start.

One situation where this definitely occurs is if you sign up for the event on the web first after launching Zwift. (Signing up in Zwift Companion seems to work fine.)

No, I signed up before, way before.

I’ve tried what you recommended, that solves my problem usually, not today.

I entered Zwift first time 9-10 minutes befor event started.

I signed up before starting Zwift via web.

It can be because you signed to two events at the same time.

I don’t believe so. One was BIKE, the other one was RUN.
And i didn’t do this for the first time and it always worked, first sign up poped up first.

@alessusnik

Thanks for sending your logs and the very complete description. We’re investigating the possibility that this was triggered by having two events that started at the same time. I’ll follow up when we learn more.

Hi, Im having issues joining Duathlon events, the companion app shows a start time of 17.32 for group C. When I logged in half hour before the start the join event button took me to start line for cycle leg, not first run. Ive since found that the actual event start time was 17.00 not 17.32 as shown on event info on companion app. Can this be corrected or updated on the event info to reflect actual start time. Have now missed two races due to this misinformation

You have to be in Run “mode” of Zwift for the count down timer of the Run part.

Zwift currently doesn’t work the way if you’re on the bike, that you get the run count down.

Hi, my point is the start time on event info is misleading. The start time shown is for cycle leg of the race but event info doesn’t make this clear. The actual event start is half an hour earlier than time shown.

Info where Jonathan? Website? ZCA? Where?


On the companion app, signed up to C group for Duathlon. Start time shown as 17.32. Duathlon actually starts at 17.00

Zwift Companion app doesn’t know how to show events from different type of sports.
For example, if you sign up for a run, and are in the bike events part of the app, it won’t show you running events that start before.
That’s a limitation of ZCA, not the race series.