No Cadence With Pioneer PM

I’ve previously been able to receive cadence data from my ANT+ Pioneer PM, but about 2 updates ago it just stopped. Not only that, but Zwift doesn’t see the PM as a device either. I’ve tried taking the battery out and seeing if the PM shows up, but it doesn’t. On real rides the PM works just fine with my Wahoo ELEMNT. I had to install the magnet to make that work once Wahoo tried to incorporate Pioneer PMs into their data fields. Once or twice I’ve had the cadence field become active in-game, but it was stuck at 191 RPMs each time.

I’ve been in touch with Zwift support. I was initially told that the dev team was looking into the issue and would be fixed soon, but it hasn’t been. Subsequent contact resulted in a recommendation to check the Zwift forums, so here I am.

Anyone have any insights into this?

Are you sure the Pioneer is still in ANT+ mode, sounds like it’s know in Pioneer’s “PMS” mode which only their computer and Wahoo’s (as of last fall) can read. When using it with the Wahoo do you get the force vectors screen? If so, then you need to switch the system back to regular ANT+ mode.

Hi James,
Thanks for the reply. I believe it is in Pedaling Monitor mode as you suggested. I will take a look and update the thread with an answer one way or the other.