New Rider - Cadence measuring but no speed. Can't move

I just paired my ant+ to my Wahoo Blue SC sensor and I am seeing my RPMs displayed, but no speed and my rider is not moving. It’s a brand new battery in the sensor. Any ideas?

I’m having the exact same problem! Can anyone help? 

I had a similar problem with my Garmin GSC10. I had the RPMs but not the speed. 


I remembered after messing around with magnet on my wheel when I ride outsdoors since it would cause problems with my GPS Speed. 

Take a look at the placement of the magnet / sensor on the wheel. 

Unpair your device and try to pair it again. It Worked for my garmin.

Hi, just downloaded and had my first session.  Using a Garmin edge 500 with gsc10 cadence/speed and hrm.   I bought a garmin ant+ dongle and seemed to have no issues picking up sensors.   Ran my garmin head unit at same time and no issues in sense that it picked up my heart rate, speed and cadence but the readout on the screen kept flicking between accurate and a zero reading.  As garmin working, sensors must be ok and guess the ant+ dongle can be only issue.   My bike was only 2m away from laptop so shouldn’t be an issue.  Any thoughts appreciated as I like the idea of this but unless I can sort that out, it’s a non starter.  Thanks

I ended up moving the magnet as close as I could get it to my Wahoo SC sensor and it started to pick up my speed. However, when logged into my wahoo app on my phone, it’s showing 18mph, but Zwift is only registering 6mph. Whats up with this? Not fun when I’m getting passed by every rider. Ill go back to trainer road if this is the case

Same thing over here. I get a cadence reading but no speed. 

Getting same issue. Can get cadence but no speed. Submitted ticket to Zwift twice and it has been 4 weeks with no response. Replaced battery, tried different ANT+ sensors, different computers, uninstalled Zwift and installed clean, tried MAC and Windows.


Has anyone figured out what this is and why?

Does Zwift not use the cadence and the power band of the trainer to calculate the speed? If that is true is this not a Zwift issue? The cadence is appearing on the screen and Zwift is not calculating the speed.

Not sure why paying for this service if I can’t get any support to fix it.


Zwift needs a speed sensor at least to estimate in game watts to estimate in game speed. A cadence sensor is not enough.

Please create a new thread so we can assist you better.