Newbie racing help needed

Found a race, enrolled, and tried “starting ride” one minute before start. It appeared like I was good to go. Race started without me. Is there something I missed?

Hi @John_Hoobler

Welcome to the forum.

What do you mean the race started without you? were you in the starting pen?

You need to start a ride in any wotld (doesn’t matter which), then press the Join Event button that should appear at bottom left of the screen.

You can join the event right from the Home screen, can’t you?

Are you on a trial? This once happened to me when my sub expired and I was on the 25k free mode.

No sir. I could see the time countdown and the “StartRide” button. Tried clicking on it over and over, no luck. Then a message that the race had started.

Hey Rob, honestly don’t know. I’ll poke around and look. Thanks!

Joined with no problem. It just wouldn’t let me start. Told me race has not started when I chose “Start ride”.

Ok, I’ll try it! I was just warming up “outside” the program. Thanks!

Do you know what happens if you enter a race which has a hardware requirement, power metre or heart rate as examples, and you arrive in the pens without appropriate hardware. Do you:

  1. Get into the start pen
  2. Start the race

John doesn’t use a heart rate sensor.

Just a thought.

1 Like

John - do you know the name and time of the race you entered.

That is a good question.

Probably a question for @shooj

Sorry, don’t know the name but it was at 6:15 last night. Distance was 12 miles if I remember right. I don’t have a heart monitor or cadence meter. Thanks for your help!

I had the same happen to me last weekend.
iTT, was on the ‘track’ going forward in the pen. Never got to start though.
Strange bug.

You can’t get in the pen without the required pairing.

1 Like

Wasnt this a bug that was ‘fixed’ in a release a few months back?

Ive certainly experienced it previously - Had to leave the event via companion app & then join a few times to then be allowed to join the event. It might have had something to do with an extremely busy WTRL ZRL night and it happening…

Maybe it’s a UCI rule–try going into the garage and lowering your sock height. :smiley:


Last week had a problem with the Monday night Stampede iTT - it showed ~90min more delay to start than it really was. I closed and re-opened Zwift and it showed the correct 3min remaining.

@John_Hoobler - Don’t leave it to the last few seconds to join the race pen. Just go ride somewhere in Zwift and join the pen when you (should) get an automatic prompt at 5min to go.


This worked! Had my first race last night. Thanks to all!!

1 Like