New Zwifter - Connection Disconnected - Zwiftalizer Log File

Hi guys. Just signed up to Zwift and have done a few rides, however every ride I have done, the riders disappear and re-appear pretty much every 5-10 seconds. (I am getting constant error messages pop up at the top of the screen) I am using a Wahoo Kickr bike, no issues connecting with that or HR strap, and all other internet applications work fine. Speed is usually 200-300mbps on a wireless 5G modem. Doesn’t matter if I am plugged directly into the modem, or using WiFi, it is the same issue.

I’ve reached out to Zwift support and tried all their suggestions, but hoping someone can look at the log file and let me know what they think might be going on?

I just completed a speed test, Ping - 16, Download - 350.6mbps, Upload - 22.6mbps.

Not sure how to attach the log file here?? I have attached screenshots of the Zwiftalizer log report.

Thanks in advance

What are you running Zwift on? Which platform?

How does your Kickr bike connect to Zwift?

Hi James. Thanks for the response. Just using my Surface Pro 8. I’ve tried a few different computers, all using Windows (the main one is Windows 11), and the Kickr bike is connecting through BT.

How does the Surface Pro connect to the Internet? I’m not a pro on this but the sheer volume of UDP errors I think indicates an internet connectivity issue.

Can you get a Zwiftaliser when using one of your Windows PCs?

I’ve tried both wifi, and direct LAN connection, but it’s the same outcome. Internet is great generally, but something is going on in the background that is causing the issue. The images are from the Surface Pro log file.

Funnily enough, I tried hotspotting from my mobile phone today and there were no issues. Short term solution, but not a high data plan…

My setup, in case it’s remotely helpful, is

Windows 10 → Powerline Adaptor —> Router
Wattbike Atom connects to PC via Ant+

The fact that you didn’t experience issue connecting over 4/5G (and I wouldn’t expect this to consume a lot of data) likely indicates something at the ISP end.

Stupid question - take it you have rebooted the router and there aren’t any firewall/parental rules that could cause an issue?

Thanks. Yup, have done that, but will check the firewall settings.