Disappearance issue on PC getting worse

I looked around and it seems I am not alone with this issue. For me, this started to get much worse from your January update.
For zwifting I use a good specs gamer PC connected to fast internet (500Mb/s speed). I connect all sensors over ANT+ which is rock solid for years.
I followed instructions on this article and it doesn’t help: Nearby Zwifters Disappearing from the Screen – A Story of Zwift Troubleshooting - Zwift Insider
All indicates that nothing is wrong on my end.

However, yesterday I had two disappearance issues on a 45min ride and today four disappearances on a 90min ride. Both on watopia.
On today’s ride I had zero errors on ANT+.
Looking at my log file I see four of these lines at exactly the same time when disappearances happened: “NETCLIENT:[WARN] UDP connection timeout…”.
Zwiftinsider article says it could be a problem on zwift servers.

Now a cry for help. Can someone at zwift support look into this issue and tell me what can I do to improve the connection, or when are you going to improve server connectivity? I can send my log file if needed.
Currently, there is no way to get a reliable connected ride on zwift.

You will need to log this with support.zwift.com - they dont respond to support calls in the forums generally.

I believe one of the many threads here mentioning this problem has a response from Zwift saying they are working on it, and its better to add your voice to that thread (if you find it) as well as logging with support.

Cheers, I will log it on support too.

1 Like

@Uros Zwift needs very little bandwidth - streaming HD videos on Netflix is only 5Mb/s. No-one needs 500 (except that person trying to simultaneously trying to stream 101 HD Netflix videos, I suppose).

How is your PC connected to your modem/router?

Is it the (typically nasty) modem/router that your ISP provides?

ISPs regularly say you now have more devices in your house, so now need a faster line speed. Unless you have multiple sets of hands and eyes, this makes no sense as all the new devices are not being used simultaneously.

As the ISPs give you a faster line speed, they often give you a slightly less nasty modem/router, which alleviates the bottleneck somewhat. Not totally, otherwise they’d have no reason to sell you an upgrade next year…

Buying a good quality (i.e. not the cheapest one you can find) modem/router is one of the best things you can do to upgrade your internet speed across multiple devices, and avoiding connectivity issues.

Connecting your PC to the modem/router via an ethernet/LAN cable is always better than cheap-O wifi components, but not necessarily better than good quality wifi components. If your wifi equipment is provided by your ISP, it is unlikely to fall into the good quality description - they WANT you to have imperfect connections so that you upgrade.

My PC is connected over fixed wired LAN network to a router first (which acts as an access point with FW disabled) and then the router goes straight to ISP’s modem.
The modem I don’t think is nasty :slight_smile: because it was all working fine last year. In fact, zwift pc, modem and router are the same throughout the years. Nothing changed on my end from the time when zwift was working fine, till now when it’s a poor experience.
I believe I have done all possible to keep my connection stable and with high bandwidth.
As stated few times, my zwift experience was absolutely ok before this disappearance issue started. And it started for me since January zwift update.

I raised a ticket through support and sent them a log file already. Let’s see what support finds out.

[edit - Your router is connected to the modem via wifi? - see my next reply]

Disabling the router FW is not a good idea, unless you have an additional firewall on the modem or PC, but then they would also need to be disabled for you to have the benefit you expect.
But disabling those would also be a bad idea.

The article you linked instructs how to configure a FW, not to disable it.
Consider that you may have firewalls in you PC, in your router, and in your modem, and you may need to follow the same instructions for each.

There is a second part that is the Zwift server - I ride nearly daily and have never once had a problem (except when my power went out for 3 hours), so I think the fault it not at the Zwift server’s end, either.

There’s a third part, which is how your ISP connects your house to the Zwift server. There will be others with more skills than me that can explain how to monitor the stability of this connection, and the relevance of any measurements you make.

That article also notes that connecting a PC to a router first, as an access point that is then connected directly to a modem, caused issues.

You are describing an identical setup to the one with issues.


I have a fairly complex wireless system at my home. In my home office, I use a separate router in the bridge mode to be able to connect my work phone which requires ethernet. The same bridge feeds Internet via a short ethernet cable to the computer which runs Zwift.

I ran a sequence of tests and found that data loss only happens when I use that bridge. If I connect my PC directly to the cable modem using a long ethernet cable (instead of wi-fi), my latency drops by about 2-3 ms, while packet losses disappear. If I connect the PC directly to wi-fi to circumvent the bridge router, packet loss also disappears."

My access point is acting as a switch really, just passes the network through. No firewall or anything happening on it. Of course there is FW on modem, I leave that on by default.
And it was working just fine before so I am sure it is not my network equipment.

I will wait for a support response before redesigning my home network if needed.

Zwift could reply that their system was also working just fine before, so it can’t be their software or equipment…
They’re unlikely to say that, of course, but it’s the same logic.

Also the same sequence of events as the article you linked, which had the same PC-accesspoint-modem setup as you describe. His Zwift setup was previously OK, too, until it wasn’t.