New user having some teething problems

Hi all. Im new to this, just got a Kickr Core and a Garmin heart rate monitor.

I did my first workout today and don’t understand how its meant to work. My understanding is that the ERG mode is meant to hold my power output stable at the designated number required by the programme, by altering the resistance of the turbo trainer.

So I was doing a 30 minute workout ‘Emily’s short mix’ to start with. My power output was all over the place. The programme was asking me to increase my power, but I was already in the biggest gear on my bike and pedalling at 120 rpm. Then, when it wanted me to warm down at the end, it said pedal at 65W or something so I slowed down and the pedals became impossible to turn.

On another 2nd workout I tried, the warm up said pedal at 80 rpm for 50W. My pedalling at 80 rpm was over 100W and I couldn’t figure out how to lower my power output.

Also my HRM was paired but on screen was just reading zero.

I am rather confused.


Hi @DanBoy, welcome to the forums.

Sounds like you aren’t connected properly (the HR reading 0 supports this theory as well), or your Kickr isn’t setup correctly for ERG mode.

First start with a spindown and make sure the firmware of the Kickr is updated using the wahoo app on your smartphone. Also make sure the settings for ERG mode are both enabled in the Wahoo app:


ERG Mode Speed Simulation: This setting simulates speed based on power input for greater accuracy of speed data. Enabling is a personal preference, will not impact overall trainer functionality, and not required (most who train with power are not concerned about speed data).

ERG Mode Power Smoothing: this setting enables smoothing reported power to eliminate small inconsistencies in pedal strokes, making power graphs appear less erratic. Enabling is a personal preference, will not impact overall trainer functionality, and not required.

Next, open Zwift and connect (if using ANT+ make sure you select the FE-C option). Enter the “training” menu and in the workout tab check to see what your FTP is set at. It should be on the right hand side and you can slide it up or down (see pic below). If you haven’t done a FTP test, you should do that first before any workouts since they are all based off the FTP number, maybe start with the ramp test if you aren’t familiar with FTP tests yet. You want your FTP to be pretty accurate to have a good workout.

1 Like

Hi. Thanks.

Yeah ERG mode is working fine on the native Wahoo app on my phone and detecting the HRM fine as well.

There seems to be an issue with Zwift on my laptop with direct pairing, because I switched to the Zwift Companion app on my phone using it as a bridge and the HRM readout was ok on that and ERG is now working properly on the turbo trainer.

So possibly an issue with either the bluetooth on my laptop or the Zwift Windows software.

Will see how it goes and report back if any more issues.

Make sure that this app is not connecting to the trainer this can cause issues. Also if using Windows I have found ANT+ to be more stable.

An additional thought regarding ERG mode: Don’t try to ‘chase’ the power in the workout. Just put your bike in a set gear (something small ring and mid-cassette always seems like a good choice for me) and pick a cadence. From there, when you come to a ‘gate’ for the next interval, just stay in the same gear and maintain the same cadence; the trainer should then adjust the resistance get you to the desired power output, but this may take a few seconds. If you try to adjust your cadence or gearing (by increasing either) the resistance will decrease. So if you just continue to increase your cadence and gearing the trainer resistance will just continue to drop and, eventually, you’ll run out of gears AND be pedaling like a maniac.

Yeah now its working properly it feels completely right. It definitely wasn’t working correctly before, it wasn’t just me I can assure you. Ive seen a few other threads saying the ERG mode isn’t working right so it looks like Im not alone but touch wood - using the Companion app paired with my laptop seems to be ok.