New routes sprint leaderboard not shown

Today in a Group Ride on “The Big Ring”, the “Fuego Flats Sprint” and the second sprint on the route “Woodland Sprint Reverse” both showed the sprint leader boards on the left hand side of the screen, but afterwards none were shown for the following 4 Sprint sections on the route.
This happened on iPadOS with the latest Zwift update installed (1.51.0).

First time I have had this issue. Did notice however that the Jersey icon was not shown for sprints I won on the general leader board shown on the right hand side, but others in the group confirmed I had won the sprint according to their sprint leader board results shown. That issue already happened during a previous group ride, no jersey icon for sprint won whilst riding on “Shorelines and Summits”.

Is there a way to reactivate the sprint leader board on the left hand side or is this a new bug?
I tried to hide and show the HUD to see if that resolved the issue but it did not during the ride.
Hopefully this does not happen again on my next ride, but thought I would report this anyway.

Sprint leaderboards seem to be working again as usual after restarting the app.

But sprint jerseys are still not shown whilst in a meet-up ?